Current time: 04-24-2014, 03:31 PM Hello There, Guest! (LoginRegister)


 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[F] Archive mode
05-18-2007, 04:52 PM
Post: #1
[F] Archive mode
A user over here has a problem with the archive mode. The links do not work: http://www.kartinfos-forum.de/archive/index.php

If you need the PHP info please send me a short PM.

Greets,
Michael
-------------
[Image: donation_drive_sig.png]
Visit this user's website Find all posts by this user
05-18-2007, 10:38 PM
Post: #2
RE: Archive mode
Maybe running the following as url.com/test.php/forum-2.html will help:
PHP Code:
<?php

echo 'Request URI: ' $_SERVER['REQUEST_URI'] . '<br />';
echo 
'PHP Self: ' $_SERVER['PHP_SELF'] . '<br />';
echo 
'Path Info: ' $_SERVER['PATH_INFO'] . '<br />';
echo 
'Redirect URL: ' $_SERVER['REDIRECT_URL']. '<br />';

?>

Post the output please if possible.

Linux Server overloading explained
Move MySQL to a second drive
Visit this user's website Find all posts by this user
05-19-2007, 12:23 PM (This post was last modified: 05-19-2007 12:24 PM by Michael S..)
Post: #3
RE: Archive mode
Here it is:
Quote:Request URI: /test.php/forum-2.html
PHP Self: /test.php
Path Info:
Redirect URL:

Greets,
Michael
-------------
[Image: donation_drive_sig.png]
Visit this user's website Find all posts by this user
05-19-2007, 03:59 PM
Post: #4
RE: Archive mode
http://community.mybboard.net/showthread...#pid129584
Visit this user's website Find all posts by this user
05-19-2007, 08:44 PM
Post: #5
RE: Archive mode
Open archive/global.php and find:
PHP Code:
    if($_SERVER['REDIRECT_URL'])
    {
        
$url $_SERVER['REDIRECT_URL'];
    } 

Replace with:
PHP Code:
    if ($_SERVER['REQUEST_URI'])
    {
        
$url $_SERVER['REQUEST_URI'];
    }
    elseif(
$_SERVER['REDIRECT_URL'])
    {
        
$url $_SERVER['REDIRECT_URL'];
    } 

Linux Server overloading explained
Move MySQL to a second drive
Visit this user's website Find all posts by this user
05-19-2007, 09:16 PM
Post: #6
RE: [F] Archive mode
This bug has been fixed in the latest code.

Please note the latest code is not live on the site or for download. An update will be released which contains this fix.
Visit this user's website Find all posts by this user


Forum Jump:


User(s) browsing this thread: 1 Guest(s)

Contact Us | MyBB | Return to Top | Return to Content | Lite (Archive) Mode | RSS Syndication