Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
stuck on Database Configuration , mySQL improved
#1
running Fedora 4.

I checked to see if mySQL was running
/etc/rc.d/init.d/mysqld status
mysqld (pid 12343) is running...

The installation wizard selected MySQL Improved
I kept the default of localhost.
I entered 1234_bb for the database username
"1234 Boards" for the database Name.
The Wizard complained:
Quote: * Could not connect to the database server at 'localhost' with the supplied username and password. Are you sure the hostname and user details are correct?
* Could not select the database '1234 Boards'. Are you sure it exists and the specified username and password have access to it?
Is there something I am supposed to do with the MySQL prior to installing the MyBB ?
Reply
#2
Have you setup a database and database user before running the installer?
[Image: sig.php]
The little boat gently drifted across the pond exactly the way a bowling ball wouldn't.
Reply
#3
MrDoom Wrote:Have you setup a database and database user before running the installer?

oh Shy
I thought that the MyBB installation process was doing that.
Reply
#4
We couldn't anyway. Most don't allow creating of databases from scripts
Reply
#5
Sad still stuck.

Where are there instructions on how to setup the MySQL for MyBB use?

I have a database called 123_Boards,
user permission for 123_bb is set to Any hosts and ALL permissions
host permissions set to Any host and ALL permissions.

but I'm still getting an error from the Wizard
Quote:Error

There seems to be one or more errors with the database configuration information that you supplied:

* Could not connect to the database server at 'localhost' with the supplied username and password. Are you sure the hostname and user details are correct?
* Could not select the database '123_Boards'. Are you sure it exists and the specified username and password have access to it?
Reply
#6
Have you installed any other MySQL apps on your web server? such as phpmyadmin?
[Image: sig.png]
Reply
#7
Snake Wrote:Have you installed any other MySQL apps on your web server? such as phpmyadmin?

There was a vtiger in the past. I deleted that database.
Yes, phpmyadmin is on the system but I don't think it is setup - all the files are in /usr/share/phpmyadmin. How do i check to see if it is actually set to run?
Reply
#8
Usually it creats a sim link in /var/www folder. In your SSH terminal (or on the host) type in
Code:
cd /var/www
ls -la

See if phpmyadmin exists. (might be in blue text)

If so then go to http://youdomainname.com/phpmyadmin in your browser.

If it gives you a connection error then you should make sure the php5-mysql or php4-sql is install.
[Image: sig.png]
Reply
#9
Snake Wrote:Usually it creats a sim link in /var/www folder. In your SSH terminal (or on the host) type in
Code:
cd /var/www
ls -la

See if phpmyadmin exists. (might be in blue text)

If so then go to http://youdomainname.com/phpmyadmin in your browser.

If it gives you a connection error then you should make sure the php5-mysql or php4-sql is install.

No phpmyadmin in /var/www.
Output from mysql.log is:
Quote:071112 10:05:57 mysqld started
071112 10:05:57 InnoDB: Started; log sequence number 0 43644
071112 10:05:57 [Warning] Found an entry in the 'db' table with empty database name; Skipped
/usr/libexec/mysqld: ready for connections.
I checked the firewall and ip port 3306 is allowed.

Then i went to the mysql command prompt and did a 'show databases;'
and it came back fine, with the 123_Boards listed.

So now i am really puzzled why the Wizard can not see anything.
Unless ... is the Wizard supposed to be run on the actual physical machine that is hosting the MyBB ?
Reply
#10
Doesn't matter if port 3306 is open to the internet or not. You apache server talks to it through the localhost. I would recommend install phpmyadmin and get it working first... If you can get phpmyadmin working then MyBB's a peace of cake.
[Image: sig.png]
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)