Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[F] SQL Error when creating Calendar Event for Single day!
#1
[I am using newest ver of mybboard] I get this error when i go to calendar and create single event...but if i change to range even if it is just for the same day it works:::::::
____________________________________________________
SQL Error:
1366 - Incorrect integer value: '' for column 'timezone' at row 1
Query:
INSERT INTO mybb_events (`cid`,`uid`,`name`,`description`,`visible`,`private`,`dateline`,`starttime`,`en​dtime`,`timezone`,`ignoretimezone`,`usingtime`,`repeats`) VALUES ('2','1','test9','test9','1','0','1232631897','1232582400','0','','0','0','N;')
________________________________________________________

Any ideas?

thanks,
Frisco, TX
#2
Can't reproduce that. A 'Single day event' adds fine.
Can you still feel the butterflies?

Free never tasted like pudding.
#3
Do do you have MySQL Strict on? What version of MyBB are you running?
#4
(01-22-2009, 02:56 PM)Ryan Gordon Wrote:  Do do you have MySQL Strict on? What version of MyBB are you running?

I am using the most recent version of mybb. I am running on a Window2003 Srv with MySQLi 5.1.30 [ON] PHP 5+. It is true that you cannot reproduce this issue if you are on linux and i do run this on a linux box too without issue but nonetheless, it is a true error. I will say that outside of this everything else runs great in windows envirionment.
thanks!
#5
That's not the problem, if you are using linux or windows. Problem is that MySQL is set to Stict, that means it will error on all 'warnings'.

Just change all instances of:
PHP Code:
$mybb->input['timezone'
to:
PHP Code:
intval($mybb->input['timezone']) 

I'm not sure why this would be happening though as the default value of input['timezone'] is 0.
#6
(01-22-2009, 03:18 PM)frisco Wrote:  
(01-22-2009, 02:56 PM)Ryan Gordon Wrote:  Do do you have MySQL Strict on? What version of MyBB are you running?

I am using the most recent version of mybb. I am running on a Window2003 Srv with MySQLi 5.1.30 [ON] PHP 5+. It is true that you cannot reproduce this issue if you are on linux and i do run this on a linux box too without issue but nonetheless, it is a true error. I will say that outside of this everything else runs great in windows envirionment.
thanks!

Are you running MySQL or Strict Mode though?
#7
(01-22-2009, 04:18 PM)Ryan Gordon Wrote:  
(01-22-2009, 03:18 PM)frisco Wrote:  
(01-22-2009, 02:56 PM)Ryan Gordon Wrote:  Do do you have MySQL Strict on? What version of MyBB are you running?

I am using the most recent version of mybb. I am running on a Window2003 Srv with MySQLi 5.1.30 [ON] PHP 5+. It is true that you cannot reproduce this issue if you are on linux and i do run this on a linux box too without issue but nonetheless, it is a true error. I will say that outside of this everything else runs great in windows envirionment.
thanks!

Are you running MySQL or Strict Mode though?

Running mysql. Not sure what Strict Mode is, can you follow based on my answer which is again, mysql. new version on that as well...
#8
Well I'm pretty sure your running Strict mode, so I'll run with that.
#9
(01-22-2009, 07:00 PM)Ryan Gordon Wrote:  Well I'm pretty sure your running Strict mode, so I'll run with that.

Okay. I will accept that but what do i need to do? Undecided
#10
Thank you for your bug report.

This bug has been fixed in our internal code repository. Please note that the problem will not be fixed here until these forums are updated.

With regards,
MyBB Group


Forum Jump:


Users browsing this thread: 1 Guest(s)