Solved: 3 Years, 10 Months, 3 Weeks, 3 Days, 20 Hours, 45 Minutes, 54 Seconds ago More theme, need to deactivate-reactivate plugins?
#1
Solved: 3 Years, 10 Months, 3 Weeks, 3 Days, 20 Hours, 45 Minutes, 54 Seconds ago
I have 1 theme which is used as the forum main theme. I wonder if I want to add more themes, will the modification made by the plugins still can be seen on the new theme? Or do I need to deactivate plugins, upload and install themes and reactivate plugins?
#2
Solved: 3 Years, 10 Months, 3 Weeks, 3 Days, 20 Hours, 45 Minutes, 54 Seconds ago
When a theme is imported it also imports templates, which don't have the modifications in them, so you need to deactivate and reactivate the plugins, unless you edit the theme settings to make it use a template set that has the modifications... this won't always work though as some templates need to use the templates that came with the theme.
Can you still feel the butterflies?

Free never tasted like pudding.
#3
Solved: 3 Years, 10 Months, 3 Weeks, 3 Days, 20 Hours, 45 Minutes, 54 Seconds ago
Ok, I just need to know this first before trying.
I installed a advertisement suite plugin by mybbaddons and deactivate it to try other plugin, then I activate it back to use it obviously. Upon activated, it seems that the plugin did not revert the template and when I activate it back, it just add another edit to the template so it is now double edited with the same thing.

So, as the solution, I need to remove it manually.

So, will deactivating and reactivating ALL plugin will then give me the same issue as my advertisement suite plugin?
#4
Solved: 3 Years, 10 Months, 3 Weeks, 3 Days, 20 Hours, 45 Minutes, 54 Seconds ago
What should happen when you deactivate is it gets removed from all templates where it exists, and then reactivating it adds it to every template again. If deactivating it doesn't remove it properly, sounds like an issue with the plugin, usually it works properly.
Can you still feel the butterflies?

Free never tasted like pudding.
#5
Solved: 3 Years, 10 Months, 3 Weeks, 3 Days, 20 Hours, 45 Minutes, 54 Seconds ago
Hmm..seems like most plugins would give me error upon reactivating the deactivate plugins.
One of them is extended buddy system which gave me this
Code:
MyBB has experienced an internal SQL error and cannot continue.

SQL Error:
    1050 - Table 'mybb_extended_buddy_requests' already exists
Query:
    CREATE TABLE `mybb_extended_buddy_requests` ( `rid` int(10) UNSIGNED NOT NULL auto_increment, `fromuid` bigint(30) UNSIGNED NOT NULL, `touid` bigint(30) UNSIGNED NOT NULL, `date` bigint(30) UNSIGNED NOT NULL default '0', PRIMARY KEY (`rid`) ) TYPE=MyISAM

I've asked the author of this plugin for help.

Looks like it will be tricky to update themes afterall.
#6
Solved: 3 Years, 10 Months, 3 Weeks, 3 Days, 20 Hours, 45 Minutes, 54 Seconds ago
It shouldn't be tricky, providing the plugins work properly there shouldn't be errors... it looks like the buddy one didn't deactivate properly either.
Can you still feel the butterflies?

Free never tasted like pudding.


Forum Jump:


Users browsing this thread: 1 Guest(s)