Current time: 07-23-2014, 05:43 PM Hello There, Guest! (LoginRegister)


 
Thread Rating:
  • 7 Vote(s) - 4.71 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Important MyBB 1.6 Beta Information - PLEASE READ
05-15-2010, 06:56 PM (This post was last modified: 07-04-2010 11:01 AM by Matt..)
Post: #1
Important MyBB 1.6 Beta Information - PLEASE READ
Welcome to the public beta of MyBB 1.6!! We know you've all been waiting for it and here it is. Before you get stuck in however, there are some things you need to know.

Can I get support for the beta?
Yes, we will be offering support for this beta. This will however be limited to core MyBB, not plugins and/or themes. Dealing with plugins and themes at this stage isn't recommended, as there is a chance you may have to roll back your database (see below).

Even though we will be supporting the beta, the support team will focus their efforts on 1.4 support as this is the current stable version and takes priority over a beta.

Please note the updated minimum requirements for MyBB 1.6:
  • The minimum PHP version has been updated to 5.1
  • SQLite 2 support has been dropped (SQLite 3 is still supported)
Is the beta stable?
This beta is being treated as unstable. It is not generally recommended that you upgrade your live production forums to this beta. There may be unknown security vulnerabilities present that you will be at risk of. Because the beta is unstable there is no guarantee of a full upgrade path to 1.6 Gold. This could mean you would be stuck on a beta version. If the beta requires more changes than initially expected then an upgrade path to Gold will not be made and you will have to roll back your database and then upgrade via the supported 1.4 > 1.6 path. However, if the beta is relatively smooth we will try to provide an upgrade path from the beta to 1.6 Gold, however do not rely on this happening as there is no guarantee it will.

If you do choose to upgrade a live forum to 1.6, you will be responsible for any data loss/corruption that may occur from it. Although we will fix issues that arise it is your responsibility to make sure that you have full backups of your 1.4 files and database, in case you need to roll back for whatever reason. You should only consider upgrading a live forum to this beta if you know what you are doing and know what to do if things go wrong. It is essential that you have complete backups of your files and database if you want to update your forum to the beta.

Similarly, if you want to use plugins that have been updated to 1.6, it is at your own risk and we would not recommend it at this stage. There may be bugs in the new 1.6 code that cause plugins to break/malfunction, and there may be a chance you will lose the data the plugin's created, as explained above.

You may by all means upgrade a copy of your live forum to 1.6 as long as the 'main' forum is untouched and you don't care what happens to the test version. It would be very beneficial to the testing process if large forums were to undergo a test upgrade, as long as it is totally separate from the live installation people are using.

Can I downgrade from 1.6 to 1.4?
No, you cannot downgrade from 1.6 to 1.4. There are many database changes in the 1.6 upgrade and we do not write code to easily undo them. If you upgrade to 1.6 and then need to go back to 1.4, your only option is to revert to your 1.4 backup, thus losing any data added whilst running 1.6. Note that as mentioned above, it is not recommended to upgrade live forums to 1.6.

I've found a bug, what do I do?
If you have found a bug in the beta please report it on our development site. Note that this site requires a separate login from your forum login here. When reporting a bug please make sure it has not already been reported, and include as much information as you can. This includes clear reproduction steps, printscreens, or anything else that can help the developers find and fix any issues to get Gold out as soon as possible.

If you find a bug whilst running on a live forum, please try to reproduce the bug on a clean install as well to see if it is a global issue or an issue with your upgraded forum. If you do this please include in your bug report if it did/did not happen on your live/test forum.

If you have found a security issue, please either use the contact form, or PM Dennis Tsang or Ryan Gordon on these forums. Please DO NOT post any security related issues on the dev site or on these forums, as this would put forums using the beta at risk.

I've got a suggestion, what do I do?
We'd love to hear your feedback on 1.6 and see how we can improve it. To do this please use the Discussion and Feedback forum. Please note that you cannot request new features; no new features will be added at this stage in the game, this forum is to suggest improvements to current functionality only. Also remember that we cannot implement all suggestions you may have.

I'm just installing a new forum, should I use this?
In short, no. If you plan on starting a new forum you should use MyBB 1.4, available here. You will be able to easily upgrade to 1.6 when it is fully released so you won't be missing out. We don't want you to start a forum on beta software and then find out you can't upgrade it.

When is Gold going to be released?
As ever, we do not know a set date. It fully depends on how well the beta goes. We will release it as soon as we can, which will be as soon as we consider it stable to use, and we need your help to make that happen faster.

How long will MyBB 1.4 be supported once 1.6 Gold is out?
Similar to 1.2, MyBB 1.4 will be supported for at least 6 months after the release of 1.6 Gold, with security fixes being released, if necessary, for around 6 months after support is stopped. After this time we would expect all users running 1.4 to have upgraded to 1.6.

Can you still feel the butterflies?

Free never tasted like pudding.
Visit this user's website Find all posts by this user


Forum Jump:


User(s) browsing this thread: 1 Guest(s)

Contact Us | MyBB | Return to Top | Return to Content | Lite (Archive) Mode | RSS Syndication