Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Button toevoegen aan een onderwerp
#1
Als je een bericht hebt geplaatst en er vervolgens weer op klikt zie je onderaan het bericht zoeken, pm bewerken etc etc staan, ik wil er graag een button aan toevoegen. Wie weet hoe ik dat kan doen.

grtz

erigo19
#2
Hey

Je kan daar dingen aan wijzigen bij de sjablonen => Post Bit Sjablonen => postbit.
Daar kom je {$post['button_edit']}{$post['button_quickdelete']}{$post['button_quote']}..... in tegen en daar zou je ook een eigen gemaakte button kunnen tussen zetten.

Ik denk dat het dat is wat je bedoelde.
#3
Ja klopt helemaal, ik heb daar een rateuser bij gezet maar krijg de button niet te zien, hoe krijg ik dat voorelkaar

grtz

erigo19
#4
Bedoel je gewoon dat de reputatieknop dat hier naast 'find' staat niet getoond wordt bij de nieuwe versie op jouw template?

Dat zou moeten werken door daar gewoon {$post['button_rep']} te plaatsen en in /images/dutch/postbit_reputation.gif te zetten.

Zelf kan je ook een knop toevoegen met dergelijke code:
<a href="jMyBB.reputation({$post['uid']},{$post['pid']});"><img src='images/dutch/postbit_reputation.gif' /></a>

(Deze doet net hetzelfde als {$post['button_rep']} en als je: ,{$post['pid']} weghaalt kan je een gewone gebruikersreputatie geven via de knop, zonder dat het aan een specifieke post gelinkt wordt)

Hopelijk ben je er iets mee. Smile
#5
ik wil dus een rateuser button er bij zetten, die zit in een template elan blue

De koppeling naar die plugin is -->> jMyBB.reputation(7);

Ik heb dus {$post['button_rateuser']} toegevoegt, en postbit_rateuser.gif aan de images map maar krijg helaas de button nog niet te zien.

Heeft dat met een javascript te maken?

grtz
#6
Waar heb je deze code dan vandaan: {$post['button_rateuser']} ? Want dan wordt die niet helemaal goed aangenomen.

Maar wat zeker moet werken is dit:
<a href="jMyBB.reputation({$post['uid']});"><img src='images/elanblue/english/rateuser.gif' /></a>

Dat doet hetzelfde maar is gewoon manueel uitgeschreven. (Als het pad naar je afbeelding anders is moet je dat wel even aanpassen)
#7
helemaal top, die werkt idd wel. Dank je voor je hulp

groetjes

erigo19
hmmm behalve dat die de button van mybb standaard laat zien en niet die van elan blue. Ga dat even uitzoeken

grtz

erigo19
#8
Ja, echt het pad van de afbeelding nakijken dat je die haalt uit het mapje van jouw template.
Maar in ieder geval fijn te horen dat het bijna in orde is dan Smile


Forum Jump:


Users browsing this thread: 1 Guest(s)