MyBB Community Forums

Full Version: high cpu usage
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
hi,
[Image: XyP4g.jpg?1]
[Image: oUnZT.jpg?1]
and other files
syndication.php
forumdisplay.php
member.php

how to fix it. What is the reason.
a few days ago without problem.
mybb version 1.6.7
my plugins
ChangUonDyU - Advanced Statistics
Dynamic Meta Tags and Canonical
ChangUonDyU - First post on all pages
PostAd
SEO Links!
Stop forum spam

my server 2gb ram ssd disk 4 cpu vps
How big is your forum (posts, average members online etc.)? have you disabled intensive features such as the forum jump menu and the navigation pagination feature? Could we also get a URL?
21000 members 4400 thread 24000 post

a few days ago without problem.
URL please?

From the URL you sent me, I see you still have certain features seen to be resource intensive enabled. Try following the below steps.

ACP > Config > Settings > Server and Optimization Options > Enable Forum Jump Menu? = No

ACP > Configuration > Settings > Show Thread Options > Show Forum Multipage Dropdown = No

You also seem to have one of the stylesheets being manually loaded via the css.php file rather than from the cache. Ensure the ./cache/themes/ directory is writeable by the webserver.

After performing the above tasks, monitor the CPU usage for about a day or so and see if they help at all.

If not, it may be a misconfiguration at your server level. What webserver are you running?
Enable Forum Jump Menu? = No
Show Forum Multipage Dropdown = No
all directory writeable

the problem continues .. my webserver nginx reverse proxy + apache
PHP Version 5.2.17 Zend Engine v2.2.0, ionCube PHP Loader v4.0.12, Zend Optimizer v3.3.9
It's odd that one stylesheet wouldn't be being read from the cache then when all the others are if the cache is indeed writeable. Could you go into the ACP and try re-saving the stylesheet with the id of 983. The stylehseet begins with the following:

div#cabecera ul#menu,
.tborder,
.tborder2,
.navigation,
input.textbox,
.boton,
.pagination_previous,
.pagination_first,
.pagination_page,
.pagination_current,
.pagination_last,
.pagination_next,
.pagination_breadcrumb,
.pm_alert,
.popup_menu,
blockquote,
.codeblock,
.adjuntos-adjunto,
img.attachment,
fieldset,
legend {
	border-radius: 5px;
	-moz-border-radius: 5px;
	-webkit-border-radius: 5px;
}

div#pie {
	border-top-left-radius: 10px;
	-moz-border-radius-topleft: 10px;
	-webkit-border-top-left-radius: 10px;
	border-top-right-radius: 10px;
	-moz-border-radius-topright: 10px;
	-webkit-border-top-right-radius: 10px;
}

I'd advise upgrading to PHP 5.3 if I was you too and disabling features such as ionCube unless you really need it.

Also, what version of Apache are you using in the background? In my experience, recent versions are far better optimised by default.
does not work.. How do disable ioncube?
Depends on how you installed PHP. Did you compile from source or simply use your distribution's package manager (yum, apt etc)?
ChangUonDyU - Advanced Statistics
ChangUonDyU - First post on all pages

Remove them.
(04-06-2012, 02:16 PM)crazy4cs Wrote: [ -> ]ChangUonDyU - Advanced Statistics
ChangUonDyU - First post on all pages

Removed them.

I disabled all plugins .. did not work