MyBB Community Forums

Full Version: How to add new toplink?
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2
I want to add some new toplinks to my forum, with images. How can I accomplish this?

Note: I am using Apart Leaf by Justin S.
(12-09-2012, 09:48 PM)TheAuthoringBay Wrote: [ -> ]I want to add some new toplinks to my forum, with images. How can I accomplish this?

You can add them manually to the header template.

I have also coded a mod that does this the very easy way, but it is paid though.

http://www.forumservices.eu/mybb/showthread.php?tid=40
How do I add them manually?
Go to ACP>Styles & Templates>Templates>THEME>Header>

Add this

<li><a href="LINK TO PAGE" target="_blank"><img src="{$mybb->settings['bburl']}/{$theme['imgdir']}/path of/image.gif"  />Home or whatever you want to name it</a></li>


(12-09-2012, 09:50 PM)borbole Wrote: [ -> ]
(12-09-2012, 09:48 PM)TheAuthoringBay Wrote: [ -> ]I want to add some new toplinks to my forum, with images. How can I accomplish this?

You can add them manually to the header template.

I have also coded a mod that does this the very easy way, but it is paid though.

http://www.forumservices.eu/mybb/showthread.php?tid=40

Lmao you aren't going to earn anything seriously because this is easy to do.
<li><a href="http://capitalcorporation.co/myawards.php" target="_blank"><img src="{$mybb->settings['bburl']}/{$theme['imgdir']}/toplinks/awards.png"  />Awards</a></li>

It made my forum look like this: http://gyazo.com/d08b4ae357d0abe6f5d7894...1355095794

What am I doing wrong?
(12-09-2012, 11:30 PM)TheAuthoringBay Wrote: [ -> ]
<li><a href="http://capitalcorporation.co/myawards.php" target="_blank"><img src="{$mybb->settings['bburl']}/{$theme['imgdir']}/toplinks/awards.png" />Awards</a></li>

It made my forum look like this: http://gyazo.com/d08b4ae357d0abe6f5d7894...1355095794

What am I doing wrong?

No I think I'm doing something wrong. (Seriously not sarcasm lol)

Try this

<li><a href="http://capitalcorporation.co/myawards.php"><img src="{$mybb->settings['bburl']}/{$theme['imgdir']}/toplinks/awards.png"  />Awards</a></li>

BTW can you also post your header template?
Same result.

<div id="container">
		<a name="top" id="top"></a>
		<div id="header">
			<div id="logo">
				<div class="wrapper">
					<a href="{$mybb->settings['bburl']}/index.php"><img src="{$theme['logo']}" alt="{$mybb->settings['bbname']}" title="{$mybb->settings['bbname']}" /></a>
				</div>
			</div>
			<div id="panel">
				<div class="upper"><!-- This div(class="upper") is closed in the header_welcomeblock_member and header_welcomeblock_guest templates -->
					<div class="wrapper">
						<ul class="menu top_links">
							<li><a href="{$mybb->settings['bburl']}/search.php" class="search">{$lang->toplinks_search}</a></li>
							<li><a href="{$mybb->settings['bburl']}/memberlist.php" class="memberlist">{$lang->toplinks_memberlist}</a></li>
							<li><a href="{$mybb->settings['bburl']}/calendar.php" class="calendar">{$lang->toplinks_calendar}</a></li>
                                                                                                                                                                      
						</ul>
						{$welcomeblock}
			</div>
		</div>
		<div id="content">
			<div class="wrapper">
				{$pm_notice}
				{$bannedwarning}
				{$bbclosedwarning}
				{$unreadreports}
				{$pending_joinrequests}
				<navigation>
				<br />
Weird, my website is down so I can't verify.

Here is my last try.

<li><a href="{$mybb->settings['bburl']}/myawards.php"><img src="http://cdn4.iconfinder.com/data/icons/pc_de_hamburg_icon_pack/16x16/bestseller.png" alt="" title="Awards" />Awards</a></li> 

Actually just replace everything in that template with this because I added the code for you.

<div id="container">
        <a name="top" id="top"></a>
        <div id="header">
            <div id="logo">
                <div class="wrapper">
                    <a href="{$mybb->settings['bburl']}/index.php"><img src="{$theme['logo']}" alt="{$mybb->settings['bbname']}" title="{$mybb->settings['bbname']}" /></a>
                </div>
            </div>
            <div id="panel">
                <div class="upper"><!-- This div(class="upper") is closed in the header_welcomeblock_member and header_welcomeblock_guest templates -->
                    <div class="wrapper">
                        <ul class="menu top_links">
                            <li><a href="{$mybb->settings['bburl']}/search.php" class="search">{$lang->toplinks_search}</a></li>
                            <li><a href="{$mybb->settings['bburl']}/memberlist.php" class="memberlist">{$lang->toplinks_memberlist}</a></li>
                            <li><a href="{$mybb->settings['bburl']}/calendar.php" class="calendar">{$lang->toplinks_calendar}</a></li>
                            <li><a href="{$mybb->settings['bburl']}/myawards.php"><img src="http://cdn4.iconfinder.com/data/icons/pc_de_hamburg_icon_pack/16x16/bestseller.png" alt="" title="Awards" />Awards</a></li> 
                                                                                                                
                        </ul>
                        {$welcomeblock}
            </div>
        </div>
        <div id="content">
            <div class="wrapper">
                {$pm_notice}
                {$bannedwarning}
                {$bbclosedwarning}
                {$unreadreports}
                {$pending_joinrequests}
                <navigation>
                <br />
The image showed, but everything still gets distorted.

http://gyazo.com/1647e03cc74910dafabe8bb...1355105638
Remove

alt="" title="Awards" 

I don't think it would do any good but PM me your site.
Pages: 1 2