MyBB Community Forums

Full Version: Member became mod automatically??
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hello, today I got a pm from a member who asked why she was upgraded to a moderator! I have never upgraded anyone and have no idea how this could have happend!

Any suggestions?
Thanks, PinkStar
have you checked her profile and administrator logs in admin panel ?
Hello .m., yes, in the pm her name had full stack of stars and had the Moderator status. I went into my admin area, did a search for people in moderator group and she was listed there. I changed her status back to regular member and clicked saved.
I've checked my admin logs and it's only me who has accessed.
This happened while I was away, and due to spambots I have registrations turned off while I'm not online and can check new signups. I did see a surge of 40% more traffic yet 40% less PVs in the last 24hrs started 36hrs ago (stats are back to normal now) and don't know if it's connected - I' still reviewing logs.

This is the first time something like has happened.
Thank you
PinkStar
^ assuming that there was no preset group promotion from regular member to staff member,
member group can be changed from database access and also from files access (ftp access is sufficient !)
if there is no such misuse then it could be a bug in the default MyBB or one of the used plugins
so far I've not come across such bug ..
Hello .m., I have never appointed a moderator and since she contacted me and was annoyed it seems like a random thing.
I have not installed any new plugins in a long time. Only issue I recently had was a stuck alert that was easily removed when empty out all old alerts. My only issue is that ip's don't seem to work properly - many users appears to have the same ip and block ip doesn't work. Other than that the script seems to work fine and have been since I installed it.

Thank you
PinkStar

There seems to be several small issues that combined makes me wonder:
After deleting the stuck alert the css changes I've made to the dropdownmenu had it's colours reset.
My ban doesn't seem to work at all now - I have added in Disallowed Email Addresses: fff* to prevent all those spambots. I had a new signup today with [email protected]
Maybe it never worked but I hadn't noticed it until resently...

Thank you