MyBB Community Forums

Full Version: Internal Error 44 | Unable to Load Extension (Tried methods)
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
My forum keeps getting the same error.

Error Type:
MyBB Error (44)
MyBB was unable to load the SQL extension. Please contact the MyBB Group for support

I tried changing the database type in inc/config.php from 'mysql' to 'mysqli' and that doesn't work. I get the same error with both 'mysqli' and 'mysql'. My site was fine before but I just moved all my files onto a new server (VPS) and installed MySQL, PHP and httpd (Apache) and am now receiving this error.

I've tried disabling all plugins just incase but doesn't make a difference, same error. Any help is appreciated guys. I absolutely love MyBB would not feel comfortable with any other forum software.

MyBB Version: 1.6.13
You haven't installed the MySQL extension for PHP.
(06-11-2014, 08:52 AM)StefanT Wrote: [ -> ]You haven't installed the MySQL extension for PHP.

How would I go about doing that?
you will need to edit your php.ini and enable mysql

or if mysql is not installed then you will need to install that.

Are you using cpanel/WHM on your VPS or is it just a raw VPS and what OS are you running?
(06-11-2014, 09:04 AM)Dannymh Wrote: [ -> ]you will need to edit your php.ini and enable mysql

or if mysql is not installed then you will need to install that.

Are you using cpanel/WHM on your VPS or is it just a raw VPS and what OS are you running?

Just a raw VPS with no panel. I've always ran my forums like this and it's the first time encountering this issue. I'm on CentOS 6.4
Try the following

- Try logging in to mysql via command line
- if this works you will need to edit your php.ini and make sure that the mysql and/or mysqli extensions are enabled
- If not you will need to install mysql (yum install mysql) (or http://dev.antoinesolutions.com/mysql) and you will need to enable the extensions in php

otherwise you may need to reinstall the LAMP stack
http://khromov.wordpress.com/2013/02/04/...php-mysql/
(06-11-2014, 09:16 AM)StefanT Wrote: [ -> ]http://www.cyberciti.biz/faq/rhel-fedora...n-for-php/
That seemed to have solved the issue. I actually thought this wasn't needed as I did not have to do this before? Weird. Thanks for the help.

(06-11-2014, 09:18 AM)Dannymh Wrote: [ -> ]Try the following

- Try logging in to mysql via command line
- if this works you will need to edit your php.ini and make sure that the mysql and/or mysqli extensions are enabled
- If not you will need to install mysql (yum install mysql) (or http://dev.antoinesolutions.com/mysql) and you will need to enable the extensions in php

otherwise you may need to reinstall the LAMP stack
http://khromov.wordpress.com/2013/02/04/...php-mysql/

Looks like my issue is now fixed. Thank you for the help guys! Smile
No worries mate glad its working