MyBB Community Forums

Full Version: Search results are redirecting to another site!!
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
For some reason my forum's search results are now redirecting to another site! What's weird is it's also a mybb site.

Everything about the search results look legit along with the link url when I hover over it...but when I click it redirects to the other site!

I'm guessing there some sort of vulnerability that I got taken advantage of?

I recently did upgrade my php to 5.5 and mysql to 5.6. Not sure if that has anything to do with it though.

PLEASE NEED URGENT HELP!
Perhaps you should show us an example...?
Well it's basically how I described it. So if I go to my site and enter "Hello" for a search term. Then I get back 3 results. Each result's title and url looks correct but then when I actually click on a result the domain changes to another site's domain.

So if the url was:

www.mydomain.com/Thread-hello-world

Then when I click on it it actually then goes to:

www.someoneelsessite.com/Thread-hello-world
in general, this type of issues need providing forum url so that someone can check & suggest solutions
Verify your Forum URL setting in the ACP.
What version are you on also?

Sounds like you may have been hacked and someone simply put their forum URL in there, or they have put some JS somewhere that is replacing the links
I found out that my htaccess file was hacked...dunno how but i removed the redirects and it's fine now. Was this a security fix since 1.6.8?
(07-26-2014, 07:10 AM)NeoCHI Wrote: [ -> ]I found out that my htaccess file was hacked...dunno how but i removed the redirects and it's fine now. Was this a security fix since 1.6.8?

lots of security fixes since 1.6.8 nothing specific to htaccess files, but they may have been able to obtain access to your server through any number of exploits
That's also why .htaccess should be 644, not 666 for chmod. Then they will not be able to write to it.
@NeoCHI
if your forum is running on older version of MyBB then it is better to upgrade to the latest available version (1.6.14)