MyBB Community Forums

Full Version: Empty lines removed from posts in quick edit
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2
Problem: Whenever we attempt to edit a post via "quick edit" all empty lines are removed from the post.

URL: tubecenter.net

Version: 1.8.4 (fresh install at 1.8.0)

Test account: Since no special permissions are required, you may create your own. I will delete your account afterwards if you wish.

Screenshots:

(original post)
[Image: 8bdac2b87c9ce6575f7143875f703da8.png]

(quick edit)
[Image: 6d31909b79648c3543ab0f630e5e9f63.png]

(full edit)
[Image: 6a5d92efae718c8ab20c25abf27f95b4.png]

Note that this error does not occur when using the full edit function. Help appreciated! Smile
My guess is that it isn't using the nl2br function when it does the ajax request to get the post content. Is it able to be reproduced here?
(10-11-2014, 12:56 PM)dragonexpert Wrote: [ -> ]My guess is that it isn't using the nl2br function when it does the ajax request to get the post content.  Is it able to be reproduced here?

No, this bug does not occur here.

Sounds like a solid guess. How do I attempt to fix this?
Are you using Quick Advanced Editor? If so, try deactivating it and see if the issue is resolved.
(10-11-2014, 01:25 PM)dragonexpert Wrote: [ -> ]Are you using Quick Advanced Editor?  If so, try deactivating it and see if the issue is resolved.

That worked, thank you! Smile
I looked through the plugin but can't really figure out how it is loading the message. Perhaps if you contact the plugin author they can figure out where it is loading the message so it can be fixed in the next update.
I'm afraid we are still having this problem somehow. Right now there are no plugins activated which interfer with the editor. :/
Nobody else having this problem?
*bump*
Someone reported it as a bug but his fix was wrong and he didn't provide any info.

We need to know:
a) if you can reproduce it on the default theme with all plugins disabled in ACP -> Configuration -> General Configuration
b) an exemplary post which causes it. Paste its whole content before and after quick edition here.

But before providing answers for a) and b) you really should upgrade to 1.8.3, otherise anyone may hack iyou in 5 minutes, especially that you provided the URL.
Pages: 1 2