MyBB Community Forums

Full Version: JS Errors after update
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
***Backstory***
I just recently upgraded to 1.8.1 and a few things worked few things didn't, whatever, I was able to fix most of them. The big project I just took on was trying to successfully get my website to us SSL. I get it, on most forums, SSL isn't really necessary since it's 'not a bank', but my site is designed specifically for tracking down and managing reporting for human trafficking so we can have an upper hand finding and rescuing trafficked persons globally, so a secure SSL connection is required.
***Backstory***

My HTTPS:// still shows a red slash through it and pulls up a browser warning, even though I have a signed cert. Additionally, these errors show up on the non https version of the site as well.

I see the following two errors:

[attachment=32891]

[attachment=32892]

Does anyone have any idea what this may be in reference to? I haven't updated my theme (if that might be the problem), because I have a lot of custom edits in my theme.



Website information: www.slaveryreport.com
I do have a test user account, please message me if you need to use it and I'll share login information. Let me also know what level permissions you require.

Thank you!


-MasterZuFu
Themes from MyBB 1.6 need to be updated in order to work on MyBB 1.8.
There are many changes in templates as well as in the stylesheets, so you might consider customizing a 1.8-compatible theme instead.
Ok. I'm not up for a project of that size quite yet, so i guess what my followup question would be is:

Do those errors cause any damage to my site or its functionality and/or will they cause any immediate problems I should be concerned about?
(10-30-2014, 04:55 PM)MasterZuFu Wrote: [ -> ]Do those errors cause any damage to my site or its functionality and/or will they cause any immediate problems I should be concerned about?

You could experience problems related to JavaScript, like inline moderation, quick reply, popup boxes messages, message editors and similar. There are some new templates and IIRC some were deleted, while other ones were modified to fit the core feature changes,so it would not be safe to use 1.6 themes on 1.8 as various defects might occur anywhere.
earlier version's theme is not compatible for using on 1.8.1 forum. if you need a simple solution then install
a new good looking compatible theme for your forum, make it default theme and force it for all user groups.

http://community.mybb.com/mods.php?actio...ory=themes
Thank you guys. Smile I'll do that for now .m. Let's hope it's compatible with my xthreads forms (that's the gold of the site, so without that I might as well not have a site).
^ oh! for xThreads forms, you need to add the required templates to the new theme. that could be a lot of manual work.

may be you can update earlier theme
upgrading guidance Wrote:Visit your Admin Control Panel, then go to Templates & Style > Templates > Find Updated Templates. This will show you a list of all the templates that have changed during the upgrade.

You can either revert these templates to their default - meaning all the changes you've made to it will be removed - or you can see a Diff Report which will show you exactly what's changed. If you have a custom theme installed, it is probably best that you look at the Diff Report and apply the changes you need.