MyBB Community Forums

Full Version: Lost password
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2
Hey all,

I lost my password. I'm unable to login due to the fact I closed my forum, and I've attempting to re-open my forum (nothing changes) and reset the password from phpmyadmin with no luck.

All the changes I make in the database don't seem to be doing anything to my forum. When I revoke privilages it brings up a SQL error. So I cannot figure whats going wrong. I just want to access my board again!

http://politicshub.co.uk/index.php

Thank you,
Matt
Are you sure you reset the password for the correct user? What's your uid and the query you run?
Yes, uid is "1" and I didn't use a query I went into the database and change the password value using a MD5 hash. I changed it to numbers too and nothing works.

Thanks,
Well, did you reset the salt column that way too?
UPDATE `mybb_users` SET `salt` = '', `password` = MD5('your new password here') WHERE `uid` = '1';
(12-07-2014, 04:29 AM)Nathan Malcolm Wrote: [ -> ]
UPDATE `mybb_users` SET `salt` = '', `password` = MD5('your new password here') WHERE `uid` = '1';

If no have salt - yes Smile

Can generate md5 here http://www.md5.cz/

example:

Password: lol123
md5: 8f036369a5cd26454949e594fb9e0a2d

Example2:

<?php
$haslo = 'test';
$salt = 'ziarno_321';
$hashed = md5($haslo.$salt);
?>

„test” salt = 15d48611a95ecf9d0f14558368200e36
„test” no have salt = 098f6bcd4621d373cade4e832627b4f6

Repeat:
UPDATE `mybb_users` SET `salt` = '', `password` = MD5('your new password here') WHERE `uid` = 'you user id here'; 

uid can look here (default is 1):
[attachment=33187]
I have salt and have entered it into that query given by Nathan. No luck and can not login.... I have been MD5 hashing too. It still won't work just throws errors.
Forget about the salt. Run the query I gave you -- just change the password.
(12-07-2014, 01:00 PM)matt4 Wrote: [ -> ]I have salt and have entered it into that query given by Nathan

That's the problem, as I said above you should reset it (set to empty).
I tried both blank and empty and it still won't let me in. I'm baffled. I've tried clearing my browser cache.
Any other ideas what this could be?

Thank you,
Pages: 1 2