MyBB Community Forums

Full Version: [SOLVED] After upgrade, Editor & buttons problem
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
SOLVED (see my other post at or near the bottom of this thread)

Hello all-- It appears that quite a few people have had this problem during the last few months, with an anomaly in which the default editor when trying to post a new thread or a reply (other than a "quick reply") does not display correctly or activate completely. Specifically, the buttons appear as text (as a vertical list of what appear to be the buttons' labels or tooltips) in what would normally be the text-entry area of the editor rather than across the top of that area below the post icons, and apparently no text entry is possible (or perhaps the text-entry area is pushed too far downward by the text labels of the buttons).

I also notice that for replies that have already been posted by the user, when clicking the Edit button at the bottom of the reply, the "Quick Edit | Full Edit" options do not appear. Instead, clicking the Edit button takes one directly to the default thread/reply editor where the anomaly below appears.

This is a screenshot from a brand new upgrade from MyBB 1.6.15 to 1.8.4 (quite a jump, I know). Everything looks beautiful and as far as I know most or all other functionality is fine although it needs to be tested by users. This default editor is the only problem noticed so far.

There are no plugins active at the forum. None of the templates have been edited or altered, and the few that had previously been slightly edited were reverted to the default templates of 1.8.4.

At the sceditor.com website, the requirements for sceditor look minimal (for head section of HTML)--


    <script type="text/javascript" src="//ajax.googleapis.com/ajax/libs/jquery/1.9.1/jquery.min.js"></script>
    <link rel="stylesheet" href="minified/themes/default.min.css" type="text/css" media="all" />
    <script type="text/javascript" src="minified/jquery.sceditor.bbcode.min.js"></script>



Here is a screenshot of what the editor looks like when someone clicks the Reply button (rather than using the Quick Reply feature).

[Image: new_thread_reply_editor_anomaly.jpg]

I know that this subject has already been discussed quite a few times, but none of the previous threads about it (that I have found) have helped me remedy the situation. I'm guessing that this is a simple problem having to do with the configuration of the default editor, which apparently is sceditor.

Thank you, if anyone can help with this issue. If a MyBB team member is willing to help, I would be happy to create an admin account for him or her at my forum to troubleshoot the issue if possible. Meanwhile, here is a temporary user account--

(forum link and user account for testing deleted from post)

-Steve
Forum is offline so the link isn't very helpful.

Have you tried Cache Manager and doing Rebuild & Reload All ? Having a test account to look at would help someone help you further.
(2015-03-04, 10:50 PM)ThemeFreaknet Wrote: [ -> ]Forum is offline so the link isn't very helpful.

Have you tried Cache Manager and doing Rebuild & Reload All ? Having a test account to look at would help someone help you further.


I'm very sorry, I've modified the .htaccess file to allow access to everyone at this time.

I will try the Cache Manager and doing Rebuild & Reload All, and will be back with the results in a few minutes.

Thank you for the suggestion. I tried the "Rebuild & Reload All" function in the Cache Manager under Tools & Maintenance, but the problem persists and still appears the same.

If you decide to login with the testing account listed in my original post above, please let me know if it does not work for you. Thank you.
Your editor shows correctly but your buttons don't work. do you have any plugins activated?

Revert your templates > your theme > Ungrouped Templates > Headerinclude back to default.
(2015-03-04, 11:11 PM)iAndrew Wrote: [ -> ]Ok nevermind it never worked, not sure why that's happening.

iAndrew-- I tried your suggestion (removing the two first calls to javascript of the three present in the head section of the headerinclude template in Ungrouped Templates), and that did indeed eliminate the vertical list of sceditor button labels or tooltips that had appeared in the text-entry area (as shown in the screenshot in the first post of the thread). However, the actual sceditor buttons are still not appearing in the editor text-entry area.

I'm going to guess that if this issue can be resolved, it will help quite a few other people who encounter the same issue. It's strange, but like most issues involving computers, despite the time it takes to troubleshoot, the solution will probably turn out to be very simple, I'm guessing.
You need to revert it back to default now.
Templates > your theme > Ungrouped Templates > Headerinclude
--

Ok it's back to as it was with it all one sided. strange
Solution to this issue

The solution to this issue, of the editor buttons not appearing or not working, is to change the options of the theme that is currently in use, because after an upgrade, the Editor Style option for the theme is set to "default" (or at least it was in my case). Instead, one of the specific styles for the editor and its buttons need to be selected from the drop-down list.

Here's the path to follow to Editor Style options in myBB 1.8--

Administrator's Control Panel -> Templates & Style -> Themes -> (your theme name) -> Edit Theme Properties (toward the bottom of the window) -> Editor Style

In my installation of myBB, upgraded from 1.6.15 to 1.8.4, the options undor "Editor Style" include:
  • default (this doesn't work and the editor buttons will not appear)
  • Buttons
  • Office-toolbar
  • Square
  • Office
  • MyBB
  • Monocons
  • Modern
Instead of leaving the option at "default," select one of the other button styles and (hopefully) your editor (for New Thread and Reply) will work correctly and the editor's formatting buttons will be displayed.

As I mentioned before, difficult to troubleshoot, but ultimately a very simple solution. Thank you to iAndrew who helped and provided moral support.  Blush