MyBB Community Forums

Full Version: Scrutinize IP // Cloudflare?
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
So as far as I was aware, to sort the issue with Cloudflare IP's showing up instead of actual user IP's I would have to set Scrutinize IP to YES.

So that was done and it's seemingly made no difference... anybody else had any similar issues?
any settings at CloudFlare that might be making this bork?
Are you using shared hosting? Or your own server? They have an apache module you have to install to translate the IP addresses.
It was fine before I made the switch from 1.6.x to 1.8.x the other day
You didn't answer either of my questions.
turning on the 'scrutinize IP' option earlier today fixed my issue I was having with my proxy service, it seems.

what's this module you speak of, spork?
Quote:what's this module you speak of, spork?

https://www.cloudflare.com/resources-dow...cloudflare
(03-12-2015, 07:07 PM)spork985 Wrote: [ -> ]You didn't answer either of my questions.

'Cloud' hosting (essentially shared)
You might want to ask your hosting provider if they can install it for you. As a hosting provider, it's very easy for them to install CloudFlare support to all clients. After the module is installed, Apache will translate the IPs appropriately and they will show up correct in MyBB, or any other software you're running, regardless of the "scrutinize" setting.
I know this is really old but this problem is weird for some shared hosting providers, I am talking about MyBB 1.8.X...

I tried all the plugins and I tried to enable the Scrutinize IP option but nothing worked.

The Scrutinize IP option worked on my old shared hosting but not on my new one... I ended up solving it really easily and by myself.

I opened the following files:
* ./global.php
* ./inc/functions.php
and I added this code at the top of both files:
if (isset($_SERVER["HTTP_CF_CONNECTING_IP"])) {
  $_SERVER['REMOTE_ADDR'] = $_SERVER["HTTP_CF_CONNECTING_IP"];
}
Then I disabled the "Scrutinize User's IP address?" option (important!) Because if I didn't disable it, the IP will still remain the Cloudflare one.

Done!

NOTE: This should be working for MyBB 1.6.X too.