MyBB Community Forums

Full Version: why do I get permission denied for "Purge Spammer" and "Mark this forum read"
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Quote:You do not have permission to access this page. This could be because of one of the following reasons:
Your account has either been suspended or you have been banned from accessing this resource.
You do not have permission to access this page. Are you trying to access administrative pages or a resource that you shouldn't be? Check in the forum rules that you are allowed to perform this action.
Your account may still be awaiting activation or moderation. (Resend Activation Code)
You have accessed this page directly rather than using appropriate forms or link.

You are currently logged in with the username: 'devnullius'
Other things to try:

Search forum

Devnullius is part of several groups, including Moderators (but not Supermoderators) and it used to work.

Now all I get is the above error message when pressing "Purge Spammer" or "Mark this forum Read".

The "Find" button does work... Isn't this strange? :s

Peace!

Devvie

(MyBB 1.8.4)


Google keywords: Problem. Error access denied: You do not have permission to access this page. This could be because of one of the following reasons for "mark this forum read" and "purge spammer" mybb 1.8
I still have this problem and got back here through Google Smile I thought to clean up the forum first before upgrading it...
is Devnullius has moderating privileges for specific forums ?
if so purge spammer might be working only at those specific forums.

which find button you were referring to ? is that the button below the posts ?

might not be able to check those issues right now. can you remind me tomorrow through a PM ..
(06-29-2017, 04:44 PM).m. Wrote: [ -> ]is Devnullius has moderating privileges for specific forums ?
if so purge spammer might be working only at those specific forums.

which find button you were referring to ? is that the button below the posts ?

might not be able to check those issues right now. can you remind me tomorrow through a PM ..

May I call you sweetie? Hello sweetie Smile

Thanks for the feedback. It was a good idea so I double checked; I'll concentrate on user 'admin' only...

It's an Administrator account (checked profile settings).
All boards, including where the spammers are enjoying themselves, have all options open for registered users (or even trial users). Administrators are all Allowed to do everything.

Checking the details with Edit Permissions confirms this: everything that enables something is set to ON.

Enjoy your evening... Smile

Hmmm... I might be on to something now... When I don't look at Permissions but at Moderators, it seems a user is missing... Might have something to do with me securing the forum.

I removed the invalid user. If I click Edit, I get: Please select a valid moderator.

I am able to add a Group or a new user though; so I added  Moderators group to the Moderator settings.

I'll reply if that doesn't work. Otherwise, thanks once again! Smile

xx Devvie


---

Post edit: I also was missing the Purge Now button for Purge Spammer. Solved with this: https://community.mybb.com/post-1195811.html

Post-edit: it still doesn't work. I carefully ran over it. I'll have someone hopefully look at it. My brain is pulp right now ;p