MyBB Community Forums

Full Version: change "Cannot upload file -"
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Cannot upload file - Too large for php post_max_size
Where is the location for this? Any help would be nice thanks!
Are you using any special language files? Can you upload any files at all, or was it actually too big?
Hello.
Umm I can upload files, just when 1 of my friend's in the forum tries to upload an 90 mb file. He said he got that error, I dunno if he has any " special language files" But I am not sure.
Any more info I will try to post.
a 90mb file? I am amazed your forum didnt explode. That is really huge and if you are serving files that size you need to look at alternatives to the myb attachment system.
(10-05-2015, 01:35 AM)Leefish Wrote: [ -> ]a 90mb file? I am amazed your forum didnt explode. That is really huge and if  you are serving files that size you need to look at alternatives to the myb attachment system.

Lol I know right?
And what do you mean by: "alternatives to the myb attachment system.?"
Do you mean, A: Attachments (5 Settings)
Various options related to the attachment system can be managed and set here.


Or B: Attachment Types?
Huh
post_max_size is a PHP option set by the host that limits the size of uploads.
(10-05-2015, 08:33 AM)StefanT Wrote: [ -> ]post_max_size is a PHP option set by the host that limits the size of uploads.

You should also increase the following:
upload_max_filesize

If you are on a shared host you can try creating a .user.ini file in the root directory of MyBB with the following:
upload_max_filesize = 100M
post_max_size = 100M
(10-05-2015, 10:29 AM)SentoWeb Wrote: [ -> ]
(10-05-2015, 08:33 AM)StefanT Wrote: [ -> ]post_max_size is a PHP option set by the host that limits the size of uploads.
Okay where do I find it? can you give me little location? thanks! Smile



You should also increase the following:
upload_max_filesize

If you are on a shared host you can try creating a .user.ini file in the root directory of MyBB with the following:
upload_max_filesize = 100M
post_max_size = 100M

If his trick does not work, I will use yours, where is the root for this?
like pub_html/
Cuz MyBB is on my home-page.
(10-05-2015, 05:54 PM)Cool-Knight Wrote: [ -> ]
(10-05-2015, 10:29 AM)SentoWeb Wrote: [ -> ]
(10-05-2015, 08:33 AM)StefanT Wrote: [ -> ]post_max_size is a PHP option set by the host that limits the size of uploads.
Okay where do I find it? can you give me little location? thanks! Smile



You should also increase the following:
upload_max_filesize

If you are on a shared host you can try creating a .user.ini file in the root directory of MyBB with the following:
upload_max_filesize = 100M
post_max_size = 100M

If his trick does not work, I will use yours, where is the root for this?
like pub_html/
Cuz MyBB is on my home-page.

If MyBB is the "home-page" you should put it in public_html/ (under WHM) or htdocs (Plesk)