MyBB Community Forums

Full Version: MyBB 1.8 - SQL Error when attempting to register.
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
So, someone told me they can't register on my forum.
I tried registering myself and got this error:

MyBB has experienced an internal SQL error and cannot continue.

SQL Error:
1364 - Field 'default_tab' doesn't have a default value
Query:
INSERT INTO mybb_users (`username`,`password`,`salt`,`loginkey`,`email`,`postnum`,`threadnum`,`avatar`,`avatartype`,`usergroup`,`additionalgroups`,`displaygroup`,`usertitle`,`regdate`,`lastactive`,`lastvisit`,`website`,`icq`,`aim`,`yahoo`,`skype`,`google`,`birthday`,`signature`,`allownotices`,`hideemail`,`subscriptionmethod`,`receivepms`,`receivefrombuddy`,`pmnotice`,`pmnotify`,`showimages`,`showvideos`,`showsigs`,`showavatars`,`showquickreply`,`showredirect`,`tpp`,`ppp`,`invisible`,`style`,`timezone`,`dstcorrection`,`threadmode`,`daysprune`,`dateformat`,`timeformat`,`regip`,`language`,`showcodebuttons`,`sourceeditor`,`buddyrequestspm`,`buddyrequestsauto`,`away`,`awaydate`,`returndate`,`awayreason`,`notepad`,`referrer`,`referrals`,`buddylist`,`ignorelist`,`pmfolders`,`warningpoints`,`moderateposts`,`moderationtime`,`suspendposting`,`suspensiontime`,`coppauser`,`classicpostbit`,`usernotes`) VALUES ('vladim','e7288ad104a3f30dfeb6891251a24b7d','fFT35JaB','b9h9jmkUGrB1yeuMkVmkmzen1FwM65Qb82WWfFrzu0kkWlBP1L','<email-was-here(censored)',0,0,'','',5,'',0,'',1455225714,1455225714,1455225714,'',0,'','','','','19-9-1994','',1,0,0,1,0,1,0,1,1,1,1,1,1,0,0,0,0,'10',2,'linear',0,'','',X'5ee279f1','',1,0,1,0,0,0,0,'','',0,0,'','','',0,0,0,0,0,0,0,'')
Did you mess with any settings?
What tab plug in are you using?
(02-12-2016, 06:54 AM)nth Wrote: [ -> ]What tab plug in are you using?

MyTabs by Ethan.
It seems that is making the problem. So after removing the plugin, it works.
Guys - what other tabs plugin can I use that DOESN'T mess up your entire forum?
you can use tabbed menu from labrocca, but you need to make some changes to be compatible with 1.8.