MyBB Community Forums

Full Version: Theme css not working
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I have a theme which was working good. I don't know what's happening now but all the CSS are gone. I figured out the CSS load when I browse my site through my phone. Then I tried to zoom in with Google Chrome and theme gets fixed only when I zoom at 150%.

Any idea what the problem may be?

Sorry, I probably posted in the wrong section, I have mybb 1.6
what is your forum url ? have you seen this general guidance on broken style ..
Your theme is not coded properly for mobile devices. Check if you have view port declaration inside the header.
(05-06-2016, 03:56 AM).m. Wrote: [ -> ]what is your forum url ? have you seen this  general guidance on broken style ..

www.asesinosloco.com

If you zoom in chrome, the CSS get to work. I dont know where the problem is.

(05-06-2016, 01:00 PM)WallBB Wrote: [ -> ]Your theme is not coded properly for mobile devices. Check if you have view port declaration inside the header.

The theme was working fine then for some reason is no longer working. I put an old backup of theme .xml but still the same problem.
Next time if it happens again, here is Simple solution Smile

Go to templates & style - theme (your theme) - click global.css - click save button at bottom - done Smile refresh forum and layout will be back, it will generate new css cache

[Image: 397bc1e642d442789fe50e7902622aae.png]
^ Try the above method by Donald Duck if that doesn't work. Do the following.
 
Download the Settings.php from yourserver/inc/ and just replace it with the one which you downloaded.
I found your issue in your global.css

@media all and (max-width: 1280px){ this is basically saying that any monitor that exceeds this resolution in width then the css does not work.

if you remove this code you have to go to the end of your global.css and remove the ending bracket. }
(05-11-2016, 11:23 AM)Burned Designs Wrote: [ -> ]I found your issue in your global.css

@media all and (max-width: 1280px){  this is basically saying that any monitor that exceeds this resolution in width then the css does not work.

if you remove this code you have to go to the end of your global.css and remove the ending bracket. }

Well the (css didn't load thats problem he don't need to remove codes)
(05-11-2016, 11:48 AM)H2e Wrote: [ -> ]
(05-11-2016, 11:23 AM)Burned Designs Wrote: [ -> ]I found your issue in your global.css

@media all and (max-width: 1280px){  this is basically saying that any monitor that exceeds this resolution in width then the css does not work.

if you remove this code you have to go to the end of your global.css and remove the ending bracket. }

Well the (css didn't load thats problem he don't need to remove codes)

Well if you look at his site and view source you can clearly see that his site does load the global.css file as if you click the link to the css you will see that code I posted actually corresponds to the viewers monitor saying if your monitor's max width is less than 1280px then run the css else don't run the css, and because this is placed above all code then no code works if the scale does not fit.
Hello there,

The forum you have posted does not have the minimum "Powered by MyBB" notice we require for technical support here. In order for us to give you further support, please add the following code to the footer template of your forum:

Admin CP --> Templates & Style --> *expand your template set* --> Footer Templates --> footer
Powered by <a href="http://www.mybb.com">MyBB</a>

I will close this thread until you have reinstated the Powered By line. Please post in the Private Inquiries forum to ask to have this thread reopened, where you can also raise any questions you have about this policy.

With regards,
MyBB Support Team