MyBB Community Forums

Full Version: two bugs found: "undefined" and error when "quick" editing a post
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
When I try to "Quick Edit" a post, there doesn't appear to be a "Save" button.  All I see within the editor window is "Undefined:", and a *blank* input line/box.  If I click to focus on this blank box and press enter, it then saves.  If I disable "Enter an Edit Reason" in ACP, this undefined blank box doesn't even show up and there doesn't seem to be a way to save a Quick Edit at all.

I'm using the theme "Virtual Blue".

Second, when I tried to rate my own thread, I get another "undefined" message with some text.  Please see my two attached screenshots! Thanks!

This is my site BTW:
bump, this is a bug right? Not just a issue with my theme?
You cannot rate your own threads

and the other issue i think its a result of your theme. Try switching to default and see if it works. That is the easiest way to test if its a theme issue or not.
I found the default theme and compared the editpost template to the theme I'm actually using and it is identical. Would the code I'm looking for be elsewhere?
identical might not always mean it doesnt work in default either. Ive had code that i had to change specifically for themes, because the default would not work in the theme template. I meant actually switch the theme to default and test. If this is the case, then you would need to modify the template of your theme to something else. But there is still no assurance that it is the theme, because you havent compared it to default.

id bet if you switch it to default, it would work, while your theme is not working.
I can "view" the default templates, but I deleted the Default theme lol
(2016-11-03, 08:02 PM)zoldos Wrote: [ -> ]I can "view" the default templates, but I deleted the Default theme lol

you can reacquire the default theme from a new mybb download at
Cool, thanks! But for whatever reason, it now always does "Full" edit and works fine. lol