MyBB Community Forums

Full Version: give guest access to attachments
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2
I have my settings to usergroup guests can download attachments. But when i go to a thread as a guest with attachments i get the unshown symbol and if i click it it goes to the login screen. How can i get it so guests can view/download attachments. 


Browsing around it seems like some attachments require login while some do not???
Hi there. From what I understand you want to allow guests to download attachments.

1) Open AdminCP
2) Click Users & Groups
3) Click Groups on the sidebar
4) Click Guests
5) Click Forums&Posts tab
6) Under viewing options check "Can download attachments?"
7) Click save user group

Please let us know if you have any further questions regarding this matter and be sure to mark this issue as solved at the top of the thread if we have resolved your issue Smile
(12-02-2016, 04:10 PM)Deatives Wrote: [ -> ]Hi there. From what I understand you want to allow guests to download attachments.

1) Open AdminCP
2) Click Users & Groups
3) Click Groups on the sidebar
4) Click Guests
5) Click Forums&Posts tab
6) Under viewing options check "Can download attachments?"
7) Click save user group

Please let us know if you have any further questions regarding this matter and be sure to mark this issue as solved at the top of the thread if we have resolved your issue Smile

ive already done this. But some attachments require log in. Let me see if i can find an example of both.

This one does not allow the guest to view it in full screen
http://python-forum.io/Thread-selenium-c...attachment
(12-02-2016, 04:17 PM)metulburr Wrote: [ -> ]
(12-02-2016, 04:10 PM)Deatives Wrote: [ -> ]Hi there. From what I understand you want to allow guests to download attachments.

1) Open AdminCP
2) Click Users & Groups
3) Click Groups on the sidebar
4) Click Guests
5) Click Forums&Posts tab
6) Under viewing options check "Can download attachments?"
7) Click save user group

Please let us know if you have any further questions regarding this matter and be sure to mark this issue as solved at the top of the thread if we have resolved your issue Smile

ive already done this. But some attachments require log in. Let me see if i can find an example of both.

This one does not allow the guest to view it in full screen
http://python-forum.io/Thread-selenium-c...attachment

Just to confirm you have already given guests the permission to download attachments using the steps I provided?
Quote:Just to confirm you have already given guests the permission to download attachments using the steps I provided?
yes...this was done before i posted this thread
(12-02-2016, 04:32 PM)metulburr Wrote: [ -> ]
Quote:Just to confirm you have already given guests the permission to download attachments using the steps I provided?
yes...this was done before i posted this thread

Please check Admin CP -> Configuration -> Attachment Types -> Edit (each type, individually) -> Available to groups

You may have attachments, even of specific file types, only available to certain groups.
(12-02-2016, 09:12 PM)The Switch Club Wrote: [ -> ]
(12-02-2016, 04:32 PM)metulburr Wrote: [ -> ]
Quote:Just to confirm you have already given guests the permission to download attachments using the steps I provided?
yes...this was done before i posted this thread

Please check Admin CP -> Configuration -> Attachment Types -> Edit (each type, individually) -> Available to groups

You may have attachments, even of specific file types, only available to certain groups.

[Image: Screenshot+2016-12-02+at+4.53.19+PM.png]

Also check invidivual forum permissions. Depending on the forum you may have "custom permissions" setup. You may need to grant them permissions to download on the actual forum sections as well.

Oops I apologize for that issue. I embedded the wrong image. It's been fixed :/
(12-02-2016, 09:55 PM)Deatives Wrote: [ -> ]
(12-02-2016, 09:12 PM)The Switch Club Wrote: [ -> ]
(12-02-2016, 04:32 PM)metulburr Wrote: [ -> ]
Quote:Just to confirm you have already given guests the permission to download attachments using the steps I provided?
yes...this was done before i posted this thread

Please check Admin CP -> Configuration -> Attachment Types -> Edit (each type, individually) -> Available to groups

You may have attachments, even of specific file types, only available to certain groups.

[Image: Screenshot+2016-12-02+at+4.53.19+PM.png]

Also check invidivual forum permissions. Depending on the forum you may have "custom permissions" setup.  You may need to grant them permissions to download on the actual forum sections as well.

Oops I apologize for that issue. I embedded the wrong image. It's been fixed :/

Mine is like this. I noticed that every one of my forums has this unchecked. But the user group guest has it checked.
Quote:Please check Admin CP -> Configuration -> Attachment Types -> Edit (each type, individually) -> Available to groups
there is no Available to groups option
(12-05-2016, 03:44 PM)metulburr Wrote: [ -> ]
(12-02-2016, 09:55 PM)Deatives Wrote: [ -> ]
(12-02-2016, 09:12 PM)The Switch Club Wrote: [ -> ]
(12-02-2016, 04:32 PM)metulburr Wrote: [ -> ]
Quote:Just to confirm you have already given guests the permission to download attachments using the steps I provided?
yes...this was done before i posted this thread

Please check Admin CP -> Configuration -> Attachment Types -> Edit (each type, individually) -> Available to groups

You may have attachments, even of specific file types, only available to certain groups.

[Image: Screenshot+2016-12-02+at+4.53.19+PM.png]

Also check invidivual forum permissions. Depending on the forum you may have "custom permissions" setup.  You may need to grant them permissions to download on the actual forum sections as well.

Oops I apologize for that issue. I embedded the wrong image. It's been fixed :/

Mine is like this. I noticed that every one of my forums has this unchecked. But the user group guest has it checked.
Quote:Please check Admin CP -> Configuration -> Attachment Types -> Edit (each type, individually) -> Available to groups
there is no Available to groups option

Did you check forum specific permissions as I recommended?
yeah they were all unchecked, i checked them.

ill have to get back about whether it works or not, as one of my users is saying it wont work. But i dont seem to have a problem at all viewing as a guest. So ill see if this fixed it for them and report back.

Thanks.
Pages: 1 2