MyBB Community Forums

Full Version: Won't stay logged in
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I'm using MyBB Version 1.8.6
PHP Version 5.6.27
SQL Engine MySQLi 5.6.32

I cannot stay logged in using Edge in Win10 - my members have been emailing me saying the same thing.
This does not happen in Chrome, but does happen in Edge.  when I log in, it sends me to the screen stating "you have been successfully logged in you will now be taken back to where you came from."  then it goes directly back to the "login screen" with everything blanked out again and I'm not logged in.

apparently this has been happening for a while and I didn't know about it until members started emailing.

my forum is located at:
http://www.christiansongwriters.org/forum

my cookies domain is set to:
.christiansongwriters.org

my cookies path is set to:
/forum/

I did have a prefix for my cookies and I tried deleting the prefix but it did not solve this problem.

I searched for advice on these boards and found several things to check and try, but none of them solved my problem.

one of the suggestions was to run "File Verification" and I tried doing that (from Chrome) but when I do, I get this error:
The following errors were encountered:
  • There was a problem communicating with the MyBB server. Please try again in a few minutes.
Waiting a few minutes and trying again yields the same results.

Can someone please help me with this issue?
Hey man, just to let you know Microsoft Edge got its name from being the replacement for the shittiest browser on earth. This is a good thing it's not working, for the love of christ warn your users away from Edge and even Chrome. Only Chromium or Firefox should be used, and in that I would recommend Firefox!
that doesn't help solve the problem, but thank you for your input.
(12-05-2016, 12:24 PM)beaglesound Wrote: [ -> ]that doesn't help solve the problem, but thank you for your input.

Big Grin

Is your actual URL http://www.christiansongwriters.org/forum/ or http://forum.christiansongwriters.org/? When I click your logo, I get sent to the latter.

It looks like you've set up a subdomain and have it pointing to a directory called /forum in your web root, correct? The issue with this is that the site can then be accessed over both URLs. It looks like you've set up your Board URL to be http://forum.christiansongwriters.org, though, so the issue is the cookie settings won't work for this hostname.

What I'd suggest is adding a redirect from http://www.christiansongwriters.org/forum/ to http://forum.christiansongwriters.org/ (i can help with this if you need it), then you'll need to change your cookie path to / instead of /forum/

Basically you want your site to only be accessible on one URL, but currently you're starting on http://www.christiansongwriters.org/forum/ which is what your cookie settings are set up for, but the forum has been configured to be on http://forum.christiansongwriters.org/, so the two don't match.

Also, after this is resolved I'd recommend you update to 1.8.7, or at least hide version numbers in the footer, otherwise you're advertising an older version is being run.
(12-05-2016, 12:36 PM)Matt Wrote: [ -> ]
(12-05-2016, 12:24 PM)beaglesound Wrote: [ -> ]that doesn't help solve the problem, but thank you for your input.

Big Grin

Is your actual URL http://www.christiansongwriters.org/forum/ or http://forum.christiansongwriters.org/? When I click your logo, I get sent to the latter.

It looks like you've set up a subdomain and have it pointing to a directory called /forum in your web root, correct? The issue with this is that the site can then be accessed over both URLs. It looks like you've set up your Board URL to be http://forum.christiansongwriters.org, though, so the issue is the cookie settings won't work for this hostname.

What I'd suggest is adding a redirect from http://www.christiansongwriters.org/forum/ to http://forum.christiansongwriters.org/ (i can help with this if you need it), then you'll need to change your cookie path to / instead of /forum/

Basically you want your site to only be accessible on one URL, but currently you're starting on http://www.christiansongwriters.org/forum/ which is what your cookie settings are set up for, but the forum has been configured to be on http://forum.christiansongwriters.org/, so the two don't match.

Also, after this is resolved I'd recommend you update to 1.8.7, or at least hide version numbers in the footer, otherwise you're advertising an older version is being run.

Hi Matt, thank you very much for your help!

My forum is actually located at:  http://www.christiansongwriters.org/forum
I do have a subdomain called forum.christiansongwriters.org
and I have a redirect on the host from http://forum.christiansongwriters.org  TO http://www.christiansongwriters.org/forum

Attached is a screenshot of my forum settings.

so are you saying I need to switch everything the other way?  have the redirect going the other direction and change the "board URL" to:  http://www.christiansongwriters.org/forum
and should I take out the board url 2 completely?

and lastly, IIRC, my host updates MyBB for me at certain intervals, or I can do it manually - but let's face it, I'm busy and if someone will do something for me, I'll let them!  so, in order to prevent this in the future, I'd be glad to hide the MyBB version numbers in the footer...where is that setting?  Smile
Hm, the redirect doesn't seem to be working, as I can still access http://forum.christiansongwriters.org/

You can do it whichever way you like, I just assumed as http://forum.christiansongwriters.org/ existed and is what your Board URL is set to, this was the preferred URL, but either is fine, as long as the settings match.

If you want the site on http://www.christiansongwriters.org/forum, you'll just need to set that as your Board URL instead of http://forum.christiansongwriters.org/

The setting to hide the version number is in ACP > Configuration > Site Details > Show Version Numbers > set this to No.
Oh, you have 2 settings... hmm, that must be a plugin but I don't think it's working if it is, personally I'd just choose one URL and stick to it.
(12-05-2016, 01:57 PM)Matt Wrote: [ -> ]Hm, the redirect doesn't seem to be working, as I can still access http://forum.christiansongwriters.org/

You can do it whichever way you like, I just assumed as http://forum.christiansongwriters.org/ existed and is what your Board URL is set to, this was the preferred URL, but either is fine, as long as the settings match.

If you want the site on http://www.christiansongwriters.org/forum, you'll just need to set that as your Board URL instead of http://forum.christiansongwriters.org/

The setting to hide the version number is in ACP > Configuration > Site Details > Show Version Numbers > set this to No.

ok, I'll try changing it, thanks.

I did change the setting to "no"

(12-05-2016, 02:01 PM)Matt Wrote: [ -> ]Oh, you have 2 settings... hmm, that must be a plugin but I don't think it's working if it is, personally I'd just choose one URL and stick to it.

ok, I only have 1 plugin, I didn't think it had added that setting, but maybe it did.  I'll take the 2nd one out and see if that works.

thanks Matt!  I'll check it out and poll some of my members and see what happens.