MyBB Community Forums

Full Version: No Style after fresh install 1.8.10
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2
After freshly installing my forums on my host, NFO, the forums themselves have no style and are unresponsive after changing the theme. the webpage is The Admin CP, however, works perfectly fine, I have reinstalled twice with no change in happenings. How can I get the theme to properly register on the forums? I have tried both the Default and the MyBBPro themes.
[Image: 1e483b8ce57a365b81b2bdfef43473ee.png]

[Image: 7410940f9a5b4a4924c56cd4a9895967.png]
Check ./cache/ and ./cache/themes/ are CHMOD to 777 - I'm not sure how you got through the installation without these being writable, but this seems to be the issue - change the permissions, and if it doesn't work straight away, re-save all the stylesheets in the ACP. Your stylesheets ( are all returning 403 Forbidden errors, so the permissions aren't set up correctly to allow access to the, or they don't exist.
Matt, he doesn't need CHMOD 777, he just needs whoever the webserver runs as to have read, write, and execute permissions. I have my directories 755.
I'm aware it's not always necessary, however as most shared servers won't work on anything other than 777, the ACP and documentation say 777 as it's easier than explaining to try 755, then 775, then 777 - evidently 755 doesn't work here (unless non-standard permissions are set currently), so by all means try 775 first, but more often than not, on shared hosts it requires 777.
I have adjusted the CHMODs, several were on 755, and re-saved all the stylesheets. I haven't seen an update in the style of the web page. One thing I have noticed is that all the files in the theme folders are all 644, should they all get adjusted to 777 or are they fine as they are?
They'll need to be writable too - can try 664 but will likely need 666.
Tried both 664 and 666 on the themes, nothing worked.
Even after saving the stylesheets again in the ACP? Does this file exist when you look in your file manager? ./forums/cache/themes/theme3/global.css

It's still giving a 403 error when visited, so if the permissions are all set correctly, I'm not sure what else it could be... to confirm, ./cache/ and ./cache/themes/ are either 775 or 777 (777 if 775 doesn't work), and the files inside are either 664 or 666 (666 if 666 doesn't work).
I have resaved the stylesheets in ACP, no change.

I checked in my FTP Client, Filezilla, and global.css does exist.

Cache, themes, and the 3 theme folders i have are all set to 777 and everything inside those theme folders is set to 666. No change still.
Hmm, okay... do you have access to the error logs on your server? There might be something in there about why these are giving a 403. Your host might be able to point you in the right direction if you're unsure where they are. If they exist, they should just be served, but something is still restricting access to them. I assume there's no custom htaccess files anywhere in these folders?
Pages: 1 2