MyBB Community Forums

Full Version: Registration/forgot password/etc emails not being sent
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hello


I am completely new to MyBB. So new that I created my account about 5 minutes ago and created my forum website about 2-3 days ago. 

Detailed description of my issue: I have been trying to figure out how to set up SMTP email for registration/forgot password/etc instances. I set up dummy accounts to see if the emails are going through when a new user registers, but to no avail. I tried to find solutions, but again, to no avail. I would appreciate any assistance with this, but please, for goodness sake, help me get my forum email up and running...! Smile  Huh  Exclamation

I have loved everything else about MyBB so far, but not being able to open up my forum because of this issue when everything else is up and running is not a nice feeling. 


Its a new installation.

No error been shown. 

I look forward to anyone helping me with this one. As per the instructions of this forum, I have provided the details that were suggested I provide when posting a query on here. 


Thank you!
Hi, I feel your pain - I had a similar experience on setting up a new board recently. I found that I needed to change from the php mail engine to smtp in the ACP and that once I'd done that it was all fine.

I then needed to make some other tweaks to ensure that confirmation emails were going out. I'll post both the support threads below.....

https://community.mybb.com/thread-209311.html

https://community.mybb.com/thread-209357.html
(03-27-2017, 08:41 PM)rockingit Wrote: [ -> ]Hi,  I feel your pain - I had a similar experience on setting up a new board recently.  I found that I needed to change from the php mail engine to smtp in the ACP and that once I'd done that it was all fine.

I then needed to make some other tweaks to ensure that confirmation emails were going out.  I'll post both the support threads below.....

https://community.mybb.com/thread-209311.html

https://community.mybb.com/thread-209357.html

Hey! Thank you for your reply. I tried the option you suggested (I made the change from PHP to SMTP a while back). It still wouldn't work. Sad
(03-27-2017, 09:15 PM)creativemind Wrote: [ -> ]
(03-27-2017, 08:41 PM)rockingit Wrote: [ -> ]Hi,  I feel your pain - I had a similar experience on setting up a new board recently.  I found that I needed to change from the php mail engine to smtp in the ACP and that once I'd done that it was all fine.

I then needed to make some other tweaks to ensure that confirmation emails were going out.  I'll post both the support threads below.....

https://community.mybb.com/thread-209311.html

https://community.mybb.com/thread-209357.html

Hey! Thank you for your reply. I tried the option you suggested (I made the change from PHP to SMTP a while back). It still wouldn't work. Sad

It might be your hosting settings - are you sure that you've got the correct port and security settings for the server?
(03-27-2017, 09:56 PM)rockingit Wrote: [ -> ]
(03-27-2017, 09:15 PM)creativemind Wrote: [ -> ]
(03-27-2017, 08:41 PM)rockingit Wrote: [ -> ]Hi,  I feel your pain - I had a similar experience on setting up a new board recently.  I found that I needed to change from the php mail engine to smtp in the ACP and that once I'd done that it was all fine.

I then needed to make some other tweaks to ensure that confirmation emails were going out.  I'll post both the support threads below.....

https://community.mybb.com/thread-209311.html

https://community.mybb.com/thread-209357.html

Hey! Thank you for your reply. I tried the option you suggested (I made the change from PHP to SMTP a while back). It still wouldn't work. Sad

It might be your hosting settings - are you sure that you've got the correct port and security settings for the server?

It seems to be working now. Just for someone's reference in the future, check if your hosting provider has included the required TXT records. Every hosting provider has some unique TXT records. Also, check your email account's score using https://www.mail-tester.com/. Through this website, you will be able to see what errors is your email account facing. The highest score is 10, which is what you should ideally aim for. Also, for checking your domain's DNS records, which you should check to ensure your DNS and SMTP settings/records are up-to-date, go to https://mxtoolbox.com/. Here, you will be able to see if your DNS records are up-to-date. Anyway, I may not know all the technicalities around this issue, but I hired someone who was able to help me out well. Just in case you are facing the same issue, I highly recommend hiring him: https://www.upwork.com/freelancers/~010c0941427abf980f (name's Oleg B). He knows his way around things and is trustworthy in his work. 

Hope this helps everyone. Good luck, and thank you, MyBB community and Rockingit! Smile Smile