MyBB Community Forums

Full Version: Login issue
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I have installed several themes, and it seems no matter which i set as default once i log in it still has the 'guest' access enabled, until i click on another theme then it registered that i'm logged in.



I think it might have something to do with cookies, but i'm unsure what the solution would be. 

Thank you.
see this guidance => faq: login

first edit ~/inc/settings.php file and put correct values for the board url, cookie domain & cookie path
then login to forum admin panel & put again correct settings at Site Details page of Configuration section
$settings['cookiedomain'] = "";
$settings['cookiepath'] = "/mybb/";
$settings['cookieprefix'] = "";

Board URL
The url to your forums.
Include the http://. Do NOT include a trailing slash.

Cookie Domain
The domain which cookies should be set to. This can remain blank. It should also start with a . so it covers all subdomains.
Cookie Path
The path which cookies are set to. We recommend setting this to the full directory path to your forums with a trailing slash.

Cookie Prefix
A prefix to append to all cookies set by MyBB. This is useful if you wish to install multiple copies of MyBB on the one domain or have other software installed which conflicts with the names of the cookies in MyBB. If not specified, no prefix will be used.

This was all set correctly as far as i can tell. In case i wasn't clear the issue isn't that it will NOT let me log in, simply that i basically need to refresh the page/pick a new theme from the default for it to see that i AM logged in.

Thank you!
where exactly you have forum files ? are they in mybb sub-folder ? are you redirecting the folder to domain url ?
yes. my files are in /mybb
under the root, and in my htcaccess i'm directing to that directory.
if you use as forum url then you should be able to login.
login from the domain url (viz., might not work.

changing cookie path to / (/ represents main directory) might work.

you & members may have to clear browser cookies [link available here] (& cache)

you may also try using ABP Multi Domain plugin
.m I just want to say thank you for all your help. (you've been a absolute dear with my other issues and i adore how quickly i can get help for my silly questions here)

Changing the cookie path did it and I adore you!