MyBB Community Forums

Full Version: Newest version of MyBB running on MySQL 5.0.33 and PHP 5.1.2 ?
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi,

Apologies if this is not the best forum for this question but I couldn't see a more appropriate one.

The question is as title :  unfortunately I cannot quickly move my webserver from its current host which is stuck on MySQL 5.0.33 and PHP 5.1.2 and can't be changed so I would like to know what is the most recent version of MyBB that will run on it ?  (The server has pre-built SW modules sourced from the hardware supplier btw, which is why it can't be easily updated.)

I do intend to move to the latest versions of MyBB as well as MySQL and PHP but that will have to wait for a new server to arrive.  In the interim I am using MyBB version 1.2.14.

Many thanks,

Boo2
at least php version 5.2 is required and php version above 5.4 is preferred

MyBB 1.6.18 can be run with php 5.1.x - however it is no longer supported.
(05-14-2017, 04:43 PM).m Wrote: [ -> ]MyBB 1.6.18 can be run with php 5.1.x - however it is no longer supported.

Thanks for that, I will try 1.6.18.

Boo2
(05-15-2017, 10:35 PM)Boo2 Wrote: [ -> ]
(05-14-2017, 04:43 PM).m Wrote: [ -> ]MyBB 1.6.18 can be run with php 5.1.x - however it is no longer supported.

Thanks for that, I will try 1.6.18.

Boo2

Don't. 1.6 is no longer supported and may contain vulnerabilities. You won't be able to get support here unless you're running MyBB 1.8.

Find a different web host.
(05-16-2017, 06:04 AM)Nathan Malcolm Wrote: [ -> ]
(05-15-2017, 10:35 PM)Boo2 Wrote: [ -> ]
(05-14-2017, 04:43 PM).m Wrote: [ -> ]MyBB 1.6.18 can be run with php 5.1.x - however it is no longer supported.

Thanks for that, I will try 1.6.18.

Boo2

Don't. 1.6 is no longer supported and may contain vulnerabilities. You won't be able to get support here unless you're running MyBB 1.8.

Find a different web host.

I'm surprised you didn't post a list of vulnerabilities to PHP 5.1...
(05-16-2017, 09:01 AM)Ben Cousins Wrote: [ -> ]I'm surprised you didn't post a list of vulnerabilities to PHP 5.1...

I could've done the same for PHP 5.2, which is the minimum requirement for 1.8, but OP is more likely to get hacked from running an outdated version of MyBB than PHP.