MyBB Community Forums

Full Version: Errors after installing plugin
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I hope this is the right forum to post this in.
I'm not 100% sure the error is being caused by the plugin or not as I only discovered it after I installed a plugin last night.

Ok the plugin I installed was View Unread Posts

It installed perfectly and I love this plugin as it finally solved an issue with mark threads as read not working.

Then how I noticed the error I'm getting was when I tried moving a user from one group into another.
The error shows up and disappears very quickly and the only way I was able to read it was to record my screen as I repeated the process.
It does move the user fine but I then logged into my host cpanel and there's a lot of errors in there all from last night/today...pretty much since I added the plugin maybe.

Errors from my cpanel log:


This is the error that flashes by quickly when I move a user from one group to another:


Here's screen shot of each of those files and the line of code which the error is reporting has a problem:

inc/functions.php line 1880 and line 1893


admin/modules/user/user.php line 2973


admin/index.php line 821


Now one other file I did edit yesterday was my global.php to try to remove index.php from the breadcrumbs, which didn't actually work so I edited misc.php as I found index.php in a line of code there and replaced it with / 
screen shot of the line I edited in my global.php  (line 943 which had no effect)


Any help to fix this error would be greatly appreciated Smile

Pm if a test account is needed please
This error cames from your avatargallery Plugin, uninstall it and try it again.
Thank you I'll try that now Smile
which editor you use for editing php files ?

editor like notepad++ is preferred for editing php files
& php files should be saved in unicode format without BoM

more details : UTF BoM
Hi .m. I'm using an app named Quick Edit which has been working wonderfully the past few years Wink

OK so I deactivated the plugin then re-installed it and getting same errors.

However while the plugin is deactivated and I move a user to another group I get no errors.

So the other night I had a problem and had to turn on user registrations settings to require admin activation.
While setting was on I created a new account to make sure it was all working properly.

What I encountered after hitting register was an error page as well telling me user_avatar_gallery.lang.php was missing from inc/language/English and kicked me off the site.
Then I looked and this new account from my admin and it was showing a blank image like a missing file.

So I downloaded the Avatar Gallery 1.1.1 again to grab the missing file and noticed that indeed there was no user_avatar_gallery.lang.php in inc/language/english but it was in inc/languages/english/admin

In the plugin install folder it didn't require it to go in inc/languages/English either but I went ahead and added it to see if it would fix the issue with new user registrations requiring admin approval, it did fix the problem Smile

So I eventually was able to return to my normal account activation settings and just now I removed that file from inc/languages/English but the error persists.....
The only way I am not getting the error is to disable the gallery plugin Sad
A fresh installed failed it fix it as well like I said above.

Thank you for the replies Smile