MyBB Community Forums

Full Version: Custom Fields
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2
I have added some custom profile fields and require them during registration. However, the fields do not display during the registration process. And when the registration is submitted, there is an error stating that the required custom profile fields that are not displayed have not been filled out.
Did you set "Show on Registration" to Yes?
I did and I get a warning for not filling the field in upon submittal.
Link to forum?

And please post a screenshot of what exactly your custom field settings look like.
(07-17-2017, 01:05 AM)fizz Wrote: [ -> ]Link to forum?

And please post a screenshot of what exactly your custom field settings look like.

www.grandroyal.org/forum2
Sorry I mean the specific settings of the individual custom field. The Name one I'm assuming you're talking about. It looks like it's not editable, which might be a problem. But yeah screenshot the page once you click on Name.
Good Day,
I am having the same issue.  I checked everything you mentioned so far but no joy.
Here are some screen shots.

Custom Fields
[Image: customfields.jpg]

Error Message
[Image: errormessage.jpg]

What it should look like
[Image: shouldbe.jpg]

Thanks.
So to be clear the screenshot I still need to see from both of you is the actual custom field settings page. If you're looking at a list of custom fields and click on edit, that's the page I need to see, how the field is defined.
[Image: editpage.jpg]
How's this one?
That "Editable By" setting needs to include the usergroup setting the value. So in this case, your Guests trying to register and set this custom field have to be able to edit it. If the field is uneditable (which it is, if you're not in an allowed usergroup) it won't display on the page but will still throw the error.
Pages: 1 2