MyBB Community Forums

Full Version: fix AMP errors
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Google identified something on my forum that I don't know anything about. As many times that I clicked on the links in comparison I do not know what they are talking about

here is some of it: from what I gather its in the construction or something.. Does someone know that can direct me? should I be concerned?  thank you

the tag 'link rel=canonical' appears more than once in the document.
AMP URL:
https://www.ebook-mecca.com/Forum-Crime[Image: url_icon.png]

Canonical URL:
https://www.ebook-mecca.com/Forum-Crime[Image: url_icon.png]
How did you use AMP ? There is no AMP in MyBB.
I don't even know what it is. However my provider restored my site a few days ago does that have anything to do with it?
Maybe you experimented with this plugin

https://community.mybb.com/thread-169502.html

Those notices will only appear if the html tag has been modified to <html amp lang="en">
Your're right Ashley1 I did in fact it is still installed although not in service. I am going to delete it now that you said that and ask Google to re crawl my site. Thank you
What is your real problem ? Did you try some SEO test and it gave you the above warning ?

Quote:A canonical link element is an HTML element that helps webmasters prevent duplicate content issues by specifying the "canonical" or "preferred" version of a web page as part of search engine optimization.

Do you use any SEO related plugins ?
(08-18-2017, 04:39 PM)meetdilip Wrote: [ -> ]What is your real problem ? Did you try some SEO test and it gave you the above warning ?

Quote:A canonical link element is an HTML element that helps webmasters prevent duplicate content issues by specifying the "canonical" or "preferred" version of a web page as part of search engine optimization.

Do you use any SEO related plugins ?

When I went into my google webmaster panel it has it under the picture of the website, and in message identifying only one forum... "Fix errors on your AMP pages View Details " with a link to my message and it says only this one fourm with a comparison link that is identical.

I am using google SEO for 1.8 I have been using that plugin for a long time on previous mybb versions when you had to make the changes manually on the php.. the only thing I can say is when my provider restored my site they used the same DB, and before when my site crashed the mybb mobile mod was installed.
There are 2 things you should know

1. I am not sure that there is a full AMP compatible version of MyBB available, yet

2. A forum like MyBB has a lesser chance of needing a canonical URL unless you do a lot of referral links.

Get rid of them.
This is very strange. I re-scanned the link and prior to doing that deleted a couple files left over from mybbmobile and now its gone...