MyBB Community Forums

Full Version: Getting Google to index my forum
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
My forum is about 6 months old with 1200+ posts.  Google knows about the domain name, but the content does not seem to be well, if at all, indexed by Google even though I see Google on the site very frequently. 
 
Is this because I have not registered the forum with Google?  Would registering help?

What do I need to do to get better exposure on search engines like Google?

Any suggestions appreciated.
 
Thanks!
You could add your site to Google Search Console then install Google Analytics. That'd go a long way. Beyond that be active on social media and share links to your forum. Google likes to see sites being active on social media. Is your site using SSL? If not set that up as Google uses it as a ranking signal. Does your site load fast (consider using Cloudflare CDN? If not speed up load times. Overtime you will rank higher in search results.
(09-12-2017, 07:14 PM)grepper Wrote: [ -> ]My forum is about 6 months old with 1200+ posts.  Google knows about the domain name, but the content does not seem to be well, if at all, indexed by Google even though I see Google on the site very frequently. 
 
Is this because I have not registered the forum with Google?  Would registering help?

What do I need to do to get better exposure on search engines like Google?

Any suggestions appreciated.
 
Thanks!

Impossible to say because we don't know anything about your forum, and you may have configuration settings that interfere with your site performing well.

It's not necessary to register, because Google has already discovered your site, however registering helps to keep track of your site with analytics.

To get better exposure you need to optimise. The best guide to optimisation is from Google itself. You can install the Google SEO plugin and make sure that you are presenting a mobile friendly version of your content.
You can send your sitemap in Google webmaster tools - https://www.google.com/webmasters/#?modal_active=none
Could you link us to your forum so we could further look into reasons Google might not be indexing it?