MyBB Community Forums

Full Version: Http to Https
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi,

I am thinking of using https rather than http. As I have been using couldflare, I already have an active certificate. I have changed the bb utl from http to https. Then it says the forum is using unauthorized scripts. When I googled it, it says the chmod permissions should be 777 for js and css. I don't think that should be the case. Because as far as I know, java script isn't something that you should set to writable for all the groups. It's just not safe.

Anyway, when I allowed the unsafe scripts to load, the other links in the forum, like sub forums are having trouble opening. Well, I have modified the htaccess file such that it would redirect all the http content to https content. Now, the chrome says "too many redirects" and the page wouldn't load at all.
So, I have reverted everything back.

When I saw godaddy's(my hosting company) tutorial about http to https, it says that modifying the htaccess file, will do the trick.
So, I am a bit lost now.
Can someone help me with this?
P.S. I am also using google SEO plugin

Thanks and advance guys
If you're talking about this forum..
http://animemangaforum.com/

It doesn't seem like you've updated your board URL.. Go to admin cp, site details... and check that it's https://
Also check every .css and headerinclude or such that none links direct to http:// if they are just change them to https:// that will do the trick.

As you can see you haven't really changed anything by the looks of it all your links are directing to http
https://prnt.sc/gxddgl

Anyways like I said update your board url to https:// after that if you get the message "unauthorized scripts" it means somewhere either your template or .css is re-directing to http instead of https:// so therefore you'll have to find out where the http links are then change them. Smile If you need further help just PM me, I've had this issue before until my web host helped me out.
(10-14-2017, 04:03 PM)Dead-i Wrote: [ -> ]If you're talking about this forum..
http://animemangaforum.com/

It doesn't seem like you've updated your board URL.. Go to admin cp, site details... and check that it's https://
Also check every .css and headerinclude or such that none links direct to http:// if they are just change them to https:// that will do the trick.

As you can see you haven't really changed anything by the looks of it all your links are directing to http
https://prnt.sc/gxddgl

Anyways like I said update your board url to https:// after that if you get the message "unauthorized scripts" it means somewhere either your template or .css is re-directing to http instead of https:// so therefore you'll have to find out where the http links are then change them. Smile If you need further help just PM me, I've had this issue before until my web host helped me out.

Well, I have reverted everything back. That's why everything is using http as of now.
My users are active during evening. So, I will try your suggestion tomorrow morning when no one is around...so that they don't face any issues. Thanks a lot dead-i ^^
(10-14-2017, 04:35 PM)Claraviolet Wrote: [ -> ]
(10-14-2017, 04:03 PM)Dead-i Wrote: [ -> ]If you're talking about this forum..
http://animemangaforum.com/

It doesn't seem like you've updated your board URL.. Go to admin cp, site details... and check that it's https://
Also check every .css and headerinclude or such that none links direct to http:// if they are just change them to https:// that will do the trick.

As you can see you haven't really changed anything by the looks of it all your links are directing to http
https://prnt.sc/gxddgl

Anyways like I said update your board url to https:// after that if you get the message "unauthorized scripts" it means somewhere either your template or .css is re-directing to http instead of https:// so therefore you'll have to find out where the http links are then change them. Smile If you need further help just PM me, I've had this issue before until my web host helped me out.

Well, I have reverted everything back. That's why everything is using http as of now.
My users are active during evening. So, I will try your suggestion tomorrow morning when no one is around...so that they don't face any issues. Thanks a lot dead-i ^^

Yep no worries, I've also signed up at your forum so message me there if you need help regarding https or anything else. Smile
(10-14-2017, 05:13 PM)Dead-i Wrote: [ -> ]
(10-14-2017, 04:35 PM)Claraviolet Wrote: [ -> ]
(10-14-2017, 04:03 PM)Dead-i Wrote: [ -> ]If you're talking about this forum..
http://animemangaforum.com/

It doesn't seem like you've updated your board URL.. Go to admin cp, site details... and check that it's https://
Also check every .css and headerinclude or such that none links direct to http:// if they are just change them to https:// that will do the trick.

As you can see you haven't really changed anything by the looks of it all your links are directing to http
https://prnt.sc/gxddgl

Anyways like I said update your board url to https:// after that if you get the message "unauthorized scripts" it means somewhere either your template or .css is re-directing to http instead of https:// so therefore you'll have to find out where the http links are then change them. Smile If you need further help just PM me, I've had this issue before until my web host helped me out.

Well, I have reverted everything back. That's why everything is using http as of now.
My users are active during evening. So, I will try your suggestion tomorrow morning when no one is around...so that they don't face any issues. Thanks a lot dead-i ^^

Yep no worries, I've also signed up at your forum so message me there if you need help regarding https or anything else. Smile

I have sent you a PM in the forum. Also, when I have tried changing the site URL in adminCP, the index page is loading fine but the sub forum is getting the too many redirects error.
(10-14-2017, 05:45 PM)Claraviolet Wrote: [ -> ]
(10-14-2017, 05:13 PM)Dead-i Wrote: [ -> ]
(10-14-2017, 04:35 PM)Claraviolet Wrote: [ -> ]
(10-14-2017, 04:03 PM)Dead-i Wrote: [ -> ]If you're talking about this forum..
http://animemangaforum.com/

It doesn't seem like you've updated your board URL.. Go to admin cp, site details... and check that it's https://
Also check every .css and headerinclude or such that none links direct to http:// if they are just change them to https:// that will do the trick.

As you can see you haven't really changed anything by the looks of it all your links are directing to http
https://prnt.sc/gxddgl

Anyways like I said update your board url to https:// after that if you get the message "unauthorized scripts" it means somewhere either your template or .css is re-directing to http instead of https:// so therefore you'll have to find out where the http links are then change them. Smile If you need further help just PM me, I've had this issue before until my web host helped me out.

Well, I have reverted everything back. That's why everything is using http as of now.
My users are active during evening. So, I will try your suggestion tomorrow morning when no one is around...so that they don't face any issues. Thanks a lot dead-i ^^

Yep no worries, I've also signed up at your forum so message me there if you need help regarding https or anything else. Smile

I have sent you a PM in the forum. Also, when I have tried changing the site URL in adminCP, the index page is loading fine but the sub forum is getting the too many redirects error.

Messaged you on your forum.
Quote:P.S. I am also using google SEO plugin

If it works when you disable Google SEO Redirect, then it's because some hosts do HTTPS in a way that Google SEO doesn't detect / looks like regular http and then it tries to redirect you to https even though you're already on https, thus it never ends. If you enable "Google SEO Redirect Debug", as forum admin you should get some debug info instead, which you can PM me to have a look at.

Adding 'SetEnv HTTPS 1' to your .htaccess might help (but will cause the same loops if you don't actually have https, as it makes Google SEO believe https is always on)
It's been sorted.