MyBB Community Forums

Full Version: quick edit showed garbled text
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
1. how to set it so the editor does not use WYSIWYG but default to source editor?
what i tried
- but still uses WYSIWYG
- this removes the toolbar completely which is not what i want
- but still uses WYSIWYG

2. quick edit shows garbled text
before hitting quick edit

after hitting quick edit

Huh Huh Huh

-------------------- edit ---------------------
for issue #1 i did

ALTER TABLE `mybb_users` CHANGE `sourceeditor` `sourceeditor` TINYINT(1) NOT NULL DEFAULT '1'; 
UPDATE `mybb_users` SET `sourceeditor` = '1' WHERE `sourceeditor` = '0'; 

"sourceeditor" => $mybb->get_input('sourceeditor', MyBB::INPUT_INT),

to member.php

<td valign="top" width="1"><input type="checkbox" class="checkbox" name="sourceeditor" id="sourceeditor" value="1" checked/> </td>
<td valign="top"><span class="smalltext"><label for="sourceeditor">{$lang->source_editor}</label></span></td>

to member_register template

$l['source_editor'] = "Put the editor in source mode by default";



----------------- edit #2 -------------------------

for my 2nd issue i just remove the use of quick edit

solution from