MyBB Community Forums

Full Version: Delayed moderation task does not work
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hello,

The task delayed moderation does not work. It works but only when there is no post in moderation queue.

For example; As soon as I perform an action to open/close a topic, the task stops working, since I check the log and it only works when there is no pending action.

I need that task to work correctly, since in my forum I am offering discount coupons for online stores, and those coupons have all expiration dates, so I need that task to work.

I have tried to manually execute it and it does not work either.

All other tasks of mybb work for me correctly, I have checked them all.

The version I use of mybb is 1.8.19. I will update to 1.8.20 in this next week, but I think it will not solve my problem, since I have tried with the 3 moderation files of version 1.8.20 and it does not work either.

Please, help me!
I have updated to the latest version and my problem persists. Can anybody help me please?
Did you activate the error log ? It may be helpfull.
(05-21-2019, 06:50 AM)Crazycat Wrote: [ -> ]Did you activate the error log ? It may be helpfull.

I've already activated it, and it has never shown any error about tasks.
That's weird...
I made some tries and can't reproduce:
  1. Select some threads and add a delayed moderation (stick)
  2. Check in table mybb_delayedmoderation => ok
  3. Deselect the threads
  4. Select another thread and unapprove it (it's in moderation queue)
  5. Run the task "delayed moderation"
  6. The threads are now sticky
I did the same but close a thread (doesn't go in moderation queue, it's immediate) rather than unapprove, it works well too.[/list]