MyBB Community Forums

Full Version: Odd posting in html since transfer to new server
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2
I moved from one VPS to another, and the mybb forum transferred with it.

I noticed suddenly that all of the old posts (old, made prior to the server migration) now have a 0 at the top.

[Image: gxieQjf.jpg]

and then any new posts made, become formatted in a sort of html, like this, with the <p>   &nbsp;    and so on  and also with the 0 at the top:
[Image: UakPEfq.jpg]
Are you sure your database encoding type is correct? Or maybe some PHP module?
I'm not quite sure to be honest, but it's worth a try.
I haven't done anything, other than - just moved to a new server.

Maybe I could try reinstalling the myBB forum software?

I did reinstall the entire forum software and re-ran the upgrade software didn't seem to help.

Also when you go to edit a post, the
at the top does not appear in the edit. The <p> </p> all that does appear, so you may edit that out and re-save, but no way to get rid of the 0 at the top because, since it does not appear in the edit, no way to delete just appears at the top when you re-save.

any URL?
Had the same Problem, the solution is here:
To make it short: Reset the "Codebuttons" template for all of your themes to default.

Worked for me
I followed the Reset the Codebuttons instructions including deleting and re-uploading the sceditor folder and now the weird html formatting <p> </p> ;&nbsp; etc. is gone from new posts, but still a
is being added at the top of each post.
(2019-12-08, 07:28 PM)mdawg Wrote: [ -> ]I followed the Reset the Codebuttons template and now the weird html formatting <p> </p> ;&nbsp; etc. is gone from new posts, but still a
is being added at the top of each post.

If every post has that, it's more likely a template or plugin output.

Check showthread template first. If no luck, you could try to troubleshoot by 1st deactivating all plugins to see if problem solved, 2nd deactivating plugins one by one to see which one is to be blame.
Well, as far as I know, this is a new thing since server transfer. The 0s showed up on each post after transfer to new server.

And I have not added any new plugins since transfer.

I reverted to original the showthread template, other than that I didn't see anything out of the ordinary in there, but I wouldn't know.

I also toggled between Andreas09-green and the default template. In the default, the 0 is still there, in blue, looks like this:
[Image: f86h6Rs.jpg]
i had the same issue when i updated mybb. All i did was changed from sceditor to rineditor and it all was fixed. rineditor is better anyway
I installed and activated rineditor, picking the moonocolor version for the theme.

The html formatting <p> </p> &nbsp; issue was already solved prior to switching to rineditor (the reset of codebuttons had solved that), but switching to rineditor did not solve the adding of the
to the top of each new post.

However one thing different is that now if I quick edit each post merely by quick editing and then saving, not even typing anything or doing anything, the 0 disappears on the re-save. I don't think rineditor solved this either this was solved with the codebuttons reset.

But in any case, the 0 is still added at the top of each new post.
Pages: 1 2