MyBB Community Forums

Full Version: Awaiting Moderation Bug post-merge
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hello,

I merged from IPB 3.4.x to myBB.  On the top of the forum display, it says:

Awaiting Moderation: 2 unapproved threads.

However, when I click on this, nothing is there in the moderation queue, either in the ModCP or ACP.

I am using the default theme and I tried rebuilding cache to see if that worked.  I also tried to unapprove a thread and then re-approve it, but it just added on to the existing count while it was under moderation.  

I can only think that perhaps it is an orphaned thread and thus I am having view permissions issues (even while on the admin account).  Is this something I can search for in the database...?
Try following queries:
SELECT * FROM mybb_threads WHERE visible = 0;
SELECT * FROM mybb_posts WHERE visible = 0 AND replyto = 0;
Ha! I forgot to mention that I had already done an SQL search on mybb_threads, but I had not done it for mybb_posts. They were hidden in there. Thank you!
It looks like there might be some inconsistency for thread visibility and the firstpost's visibility. We will check it later.

Thanks for your report!