MyBB Community Forums

Full Version: IPB merge issue
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Source: IPB version 2.3.6
Destination: Fresh install MyBB version 1.4.5
Size: 37,500 posts

I can not send the forum database as it is a private forum.

Issue #1: Strange characters

Example being a catergory title that comes out as 'Public News & Announcements' where it should be 'Public News & Announcements'.

Another example being how quotes are handled, ending up looking like '"I disagree." - Bob' instead of using proper " marks.

Not sure what has been causing this. I had this same issue with a prior version of the merge system for 1.4 but never figured it out, looking for ideas.

Issue #2: Failed attachment importing

Inserting attachment #21...
Warning [2] fwrite(): supplied argument is not a valid stream resource - Line: 1549 - File: convert/boards/ipb2.php PHP 5.2.6-2ubuntu4.2 (Linux)
File Line Function
[PHP] errorHandler->error
/convert/boards/ipb2.php 1549 fwrite
/convert/index.php 1413 Convert_ipb2->import_attachments
Did you use the Merge System Beta 3 or Beta 4?
Hey Ryan,

I used Beta 4, downloaded it this morning.
I should have noted in Issue #2 that the same error is generated for all attachments, not just #21.
I also get the same error for '&'.
I me also same error
Hey Ryan,

Any thoughts or other information I need to provide?
So, as an update... I went ahead and converted to SMF which worked fine, later this weekend I will likely try to convert from SMF to MyBB and see how that goes. Not ideal, but if it works it works.