MyBB Community Forums

Full Version: SQL Error
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2
Merging 1.6 with 1.6
Error appears at ''Creating fields for tracking data during the Merge process (This may take a while)...''

MyBB has experienced an internal SQL error and cannot continue.

SQL Error:
1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'TYPE=MyISAM' at line 6
CREATE TABLE mybb_post_trackers ( pid int NOT NULL default '0', import_pid int NOT NULL default '0', import_uid int NOT NULL default '0', KEY pid (pid,import_pid) ) TYPE=MyISAM;
Using MySQL 5.5?? You'd need to change all of the TYPE clauses to ENGINE.
Deleted my other post, it doesn't apply anymore.
So how exactly do I do that?
You would have to open up all the merger files and change any appearances of TYPE in the SQL queries to ENGINE.
I looked through quite a few and couldn't find any at all.
This appears in four places in the Merge System. I've opened a bug report on this. You can get the 4 locations there, though the line numbers may not be exact. This will be fixed in Merge System 1.6.2.
Only 1 of those files exist in the merge system, I've made that change and will test shortly.
That hasn't worked. I changed type to engine in functions.php, same error.
There are 3 places in functions.php - you have to do them all. And yeah I did that off the trunk, the current download doesn't have the debug system in it.

If you did all 3 and still having the issue, you can always use fgrep (Linux or Mac) or Find in Files (available with certain IDEs on Windoze) to find where it is. For fgrep, just go into the merge folder and issue:
fgrep -Rn TYPE\= *
For Find in Files use the search term

If you have neither, I can search for you tomorrow.
For me there was just 1 place.
Ok, I thought there was at least two in the 1.6.1, but I just did a quick fgrep myself and yes, only one.

Silly question but... you did remember to reupload the file after you changed it, yes? If the error is exactly the same, it isn't changed on the server where you're trying to run this.
Pages: 1 2