MyBB Community Forums

Full Version: Go to last read post not working
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2
The "go to your last read post" is not working for me. I took a picture from mybb of what I mean:

[Image: capturebpu.png]

When I click the green arrow like the one in the above picture ^ , instead of it directing me to that threads unread posts by me, it directs me to the beginning of the forum. The same thing happens to me when I click on the green arrow in the quote box. Am I missing a JavaScript file or something?

Thanks! Smile
(03-21-2011, 12:39 AM)mithokey Wrote: [ -> ]...Am I missing a JavaScript file or something?

Thanks! Smile

Let's find out.
(This is a starting point, not a full solution)

1) In your ACP go to the ' forumdisplay_threadlist ' template
2) Options > Full Edit >> Copy it all into Notepad
3) Revert to original
Now...

4a) Is the problem 'fixed' or still the same?
4b) 'Fixed' = The issue is in the modified version of your template.
'Still the same' = the problem is somewhere else, not necessarily javascript.

ps. Later remember your modified template is sitting in Notepad. Toungue
where is the original templete? (and thanks) Smile
I mean, how do I revert it?
I changed it to the Default templete's code and still does not work :\
(03-21-2011, 01:35 AM)mithokey Wrote: [ -> ]...
I changed it to the Default templete's code and still does not work :\

You are closer to a solution. Smile
Maybe you are missing a file somehow:
The next thing I would do is get a fresh copy of MyBB, delete the inc/settings.php file, and upload to your site.

Then all your files should be in the right place.
Hopefully that will work.

OK, did that but it still does not work.. :\

Maybe its in another file?
You 'cleaned' (reverted) the template and uploaded fresh files?
>>> Have you added jQuery with using 'no conflict'?

#
Someone else will see this and be able to help you.
Yep, and still does not work. I figured out it isn't a problem with the forumdisplay, but is something different. When I click on the first or 2nd post of a thread etc, the url is correct (it ends in pid), but it doesn't go to that post.
The problem is your theme. Its missing the anchor placeholders for the posts that will specify where to scroll to.

Check your Post Bit Templates >> postbit

at the very top you should have
<a name="pid{$post['pid']}" id="pid{$post['pid']}"></a>
Thanks, I did not have that in my postbit but I added it and still doesn't work. Do you think something else may be missing from my postbit... because I did edit it a while ago?

This is the code:

<a name="pid{$post['pid']}" id="pid{$post['pid']}"></a>
{$ignore_bit}
<table border="0" cellspacing="{$theme['borderwidth']}" cellpadding="{$theme['tablespace']}" class="tborder" style="{$post_extra_style} {$post_visibility}" id="post_{$post['pid']}">
<tr>
<td class="tcat" colspan="2">
<span style="float: right;">
{$post['posturl']}
</span>
{$post['postdate']} {$post['posttime']}
</td>
</tr>

	<tr>
		<td class="postbit" rowspan="2" width="200px" valign="top" style="white-space: nowrap; text-align: center;"><a name="pid{$post['pid']}" id="pid{$post['pid']}"></a>
		<div class="postbit_name">{$post['onlinestatus']}{$post['profilelink']}<br />
		<span style="float: right;">{$post['userstars']}</span><span class="postbit_usertitle">{$post['usertitle']}</span></div>
		<span class="smalltext">
                         {$post['usertitle']}<br />
                         {$post['userstars']}
                         {$post['groupimage']}
                         {$post['user_details']}
		</span>
	</td>
	<td class="trow1" valign="top">
		<table width="100%">
			<tr><td><span class="smalltext"><strong>{$post['icon']}{$post['subject']} {$post['subject_extra']}</strong></span>
			<br />
			<div id="pid_{$post['pid']}" style="padding: 5px 0 5px 0;">
				{$post['message']}
			</div>
			{$post['attachments']}
			{$post['signature']}
			<div style="text-align: right; vertical-align: bottom;" id="post_meta_{$post['pid']}">
				<div id="edited_by_{$post['pid']}">{$post['editedmsg']}</div>
				{$post['iplogged']}
			</div>
		</td></tr>
	</table>
</td>
</tr>
<tr>
	<td class="trow2" style="vertical-align: middle; height: 10px;">
		<table width="100%" border="0" cellpadding="0" cellspacing="0">
			<tr valign="bottom">
				<td align="left" ><span class="smalltext">{$post['button_email']}{$post['button_pm']}{$post['button_www']}{$post['button_find']}{$post['button_rep']}</span></td>
				<td align="right">{$post['button_tyl']}{$post['button_edit']}{$post['button_quickdelete']}{$post['button_quote']}{$post['button_multiquote']}{$post['button_report']}{$post['button_warn']}{$post['button_reply_pm']}{$post['button_replyall_pm']}{$post['button_forward_pm']}{$post['button_delete_pm']}</td>
			</tr>
		</table>
	</td>
</tr>
</table>
Are you sure you're adding it to the right theme's template?? I am looking at your site and I don't see the addition in the source.
Pages: 1 2