Thread Rating:
  • 36 Vote(s) - 4.22 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[For 1.6] Google SEO 1.6.8 [EOL]
This user has been denied support. This user has been denied support.
1.6.7 has two minor changes:
- the noindex forum setting did not apply to the first fid in the list
- improved https detection
Reply
Sorry, found it
Reply
<error>
<dateline>1399032774</dateline>
<script>inc/plugins/google_seo.php</script>
<line>211</line>
<type>2</type>
<friendly_type>Warning</friendly_type>
<message>Illegal string offset 'pid'</message>
</error>
Reply
This user has been denied support. This user has been denied support.
@hkkp: apparently something (another plugin?) causes global $post to be set to a string when MyBB itself only ever uses it as an array. You could provoke thousands of errors this way; PHP just isn't a language where you typecheck everything.
Reply
the error is not in php 5.3
Reply
Question 
Hi frostschutz,
These settings cause two units are available?

1. http://i.imgur.com/t8hzcQs.png

2. http://i.imgur.com/qJQ2Eh7.png

Different tasks or are doing the same process if so, why two separate attached in place?
MyBB Support - MyBB Themes - MyBB Plugins
≧◔◡◔≦ I Love You MyBB (>‿♥)
Reply
This user has been denied support. This user has been denied support.
one is for the redirect behaviour (when someone actually clicks on a link)
- default: query tid for a link that has none (/post-12345.html)
- verify: query tid even if it was given (/thread-123-post-12345.html, when post-12345 is not actually in the thread 123)
- ignore: query nothing, redirect nothing

the other is for the url behaviour (what a link shows up in the HTML source, or when hovering without clicking)
- default: query tid for a post link that has none (so it will show Thread-Title instead of /post-1235.html)
- verify: always query the tid even if given - should never need this but ...
- ignore: stick with /post-12345.html, don't even try to produce SEO URL for post links


If in doubt, stick to default. Although for some reason, post links seem to be broken in MyBB itself currently, I'm pretty sure they used to work even after posts were moved to other threads, but ... if you set the redirect to verify, Google SEO takes care of it and redirects links to moved posts.
Reply
After i updated to 1.6.7 i have the warning to add these lines to .htaccess:

# Google SEO Sitemap:
RewriteRule ^sitemap\-([^./]+)\.xml$ misc.php?google_seo_sitemap=$1 [L,QSA,NC]

# Google SEO URL Forums:
RewriteRule ^Forum\-([^./]+)$ forumdisplay.php?google_seo_forum=$1 [L,QSA,NC]

# Google SEO URL Threads:
RewriteRule ^Thread\-([^./]+)$ showthread.php?google_seo_thread=$1 [L,QSA,NC]

# Google SEO URL Announcements:
RewriteRule ^Announcement\-([^./]+)$ announcements.php?google_seo_announcement=$1 [L,QSA,NC]

# Google SEO URL Users:
RewriteRule ^User\-([^./]+)$ member.php?action=profile&google_seo_user=$1 [L,QSA,NC]

# Google SEO URL Calendars:
RewriteRule ^Calendar\-([^./]+)$ calendar.php?google_seo_calendar=$1 [L,QSA,NC]

# Google SEO URL Events:
RewriteRule ^Event\-([^./]+)$ calendar.php?action=event&google_seo_event=$1 [L,QSA,NC]

but they are already added, so what the problem?

By the way i don't experience any particular problem, the SEO seems working well.
I also tried Revert changes and apply again, but didnt resolved.

Thanks in advice.
Reply
Hello i have installed this plugin to my forums today www.clan.genesis.com/index.php but when ever i open a new topic or something it says

Not Found

The requested URL /Forum-General-Chat was not found on this server.

like open http://www.clan-genesis.com/Forum-General-Chat
Reply
(05-01-2014, 01:10 PM)frostschutz Wrote: 1.6.7 has two minor changes:
- the noindex forum setting did not apply to the first fid in the list
- improved https detection

Board URL is set to 'https://www.site.com', but you currently seem to be on 'http://www.site.com'. A wrong Board URL setting may cause problems with Redirect.

Undecided
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)