Jump to the post that solved this thread.
Solved: 6 Years ago Set new members to subscribe Instant email
#1
Solved: 6 Years ago
How can I set all new member’s (those who will join in future) Default Thread Subscription Mode to Instant email notification in UserCP so that they will automatically be subscribed to any threads they post in.

In Member Templates I edited member_register like so.

    <select name="subscriptionmethod" id="subscriptionmethod">
        <option value="0" {$instant_email_subscribe_selected}>{$lang->instant_email_subscribe}</option>
        <option value="1" {$instant_email_subscribe_selected}>{$lang->instant_email_subscribe}</option>
        <option value="2" {$instant_email_subscribe_selected}>{$lang->instant_email_subscribe}</option>
        <option value="3" {$instant_email_subscribe_selected}>{$lang->instant_email_subscribe}</option>
    </select>

The above does automatically select Instant email notification when registering but later in UserCP the subscription mode is still Do not subscribe. I want everyone who joins the forum to have their subscription mode set to Instant email.

Using MyBB 1.8.4

Thank you for your help.
My forum has a higher purpose.
Reply
#2
Solved: 6 Years ago
The following will select instant email subscribe on registration:

<option value="2" {$instant_email_subscribe_selected} selected="selected">{$lang->instant_email_subscribe}</option>
Find me here or at my new blog about MyBB, Web Design, SEO
My Services
MyBB Themes
Reply
#3
Solved: 6 Years ago
(2015-03-04, 08:49 PM)ThemeFreaknet Wrote: The following will select instant email subscribe on registration:



<option value="2" {$instant_email_subscribe_selected} selected="selected">{$lang->instant_email_subscribe}</option>

Sorry for not answering sooner.

That works, thank you. This will spare me from having to do this for every new member who joins but forgets to set this, and they almost always do!
My forum has a higher purpose.
Reply
#4
Solved: 6 Years ago
Hi,

I'm having the same problem as you. I managed to fix it on the registration page, but later on, in the Usercp, it's not set to "instant emails", but rather to "do not subscribe". How do I set it to "instant emails" on usercp as well? On the registration page, it's been done, but on usercp, it isn't.

Any help will be appreciated.

Thanks
Reply
#5
Solved: 6 Years ago
Do the same edit in the usercp_options template.

And to avoid HTML syntax error (duplicate attribute) remove {$instant_email_subscribe_selected} and {$instant_email_subscribe_selected} from that option. Or from all options if it should be always selected.
Reply
Jump to the post that solved this thread.


Forum Jump:


Users browsing this thread: 1 Guest(s)