Jump to the post that solved this thread.
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Solved: 4 Years, 6 Months, 2 Weeks ago I have no ability to delete groups?
#1
Solved: 4 Years, 6 Months, 2 Weeks ago
After merging from IPS 4.0 to MyBB 1.8.

I noticed that it would make two empty groups, i do not care about this. So I want to delete these two groups, however there are no option to do so?

[Image: rCykKff.png]

How could I do this? I know that there are certain members in this group, but I guess if i delete them via AdminCP, they'll be put back automatically. Buuuuuuuuut, there are no option to delete the group.
Reply
#2
Solved: 4 Years, 6 Months, 2 Weeks ago
Run the following query and post all the results:
SELECT * FROM mybb_usergroups
Jack.D
Aspiring Web Developer
Reply
#3
Solved: 4 Years, 6 Months, 2 Weeks ago
I renamed the empty group some how, but still no delete option.

I am using phpmyadmin, i got the sql file.. <- snip ->

(I named them test and test2)
Reply
#4
Solved: 4 Years, 6 Months, 2 Weeks ago
Go into phpMyAdmin go to the table called "mybb_users" click search and find the users where usergroup or additionalgroups is = 8 and set their user group to 2 and do the same for group id 9.

Then delete the groups in phpMyAdmin and AUTO_INCREMENT to 7
Jack.D
Aspiring Web Developer
Reply
#5
Solved: 4 Years, 6 Months, 2 Weeks ago
(05-17-2015, 05:26 PM)Jack.D Wrote: Go into phpMyAdmin go to the table called "mybb_users" click search and find the users where usergroup or additionalgroups is = 8 and set their user group to 2 and do the same for group id 9.

Then delete the groups in phpMyAdmin and AUTO_INCREMENT to 7

Thank you.

I deleted the groups + set everyone to 2 (members).

I do not understand "AUTO_INCREMENT to 7" though.

Options was restored also: http://i.imgur.com/iF0VGQb.png

ok, i added a new group and it broke again (no edit).. guess its that AUTO_INCREMENT needed ?
Reply
#6
Solved: 4 Years, 6 Months, 2 Weeks ago
Add another usergroup and show me again.
Jack.D
Aspiring Web Developer
Reply
#7
Solved: 4 Years, 6 Months, 2 Weeks ago
(05-17-2015, 05:46 PM)Jack.D Wrote: Add another usergroup and show me again.

https://mega.co.nz/#!yQInFaYR!YXnJ7cQBIo...mfeLWnAajo

Here you go, thank you so much btw.

The new group is "Media Team". After adding this, the options were gone again.
Reply
#8
Solved: 4 Years, 6 Months, 2 Weeks ago
Have you changed any core files or installed any plugins? I'll go look through the MyBB Source code now and look to see if I can work out why.
Jack.D
Aspiring Web Developer
Reply
#9
Solved: 4 Years, 6 Months, 2 Weeks ago
(05-17-2015, 06:03 PM)Jack.D Wrote: Have you changed any core files or installed any plugins? I'll go look through the MyBB Source code now and look to see if I can work out why.

No I have not.

1.) I installed MyBB.
2.) I imported all users & groups from IPS 4.0.5.1
3.) I rebuilt, cache and recounted all that.

That's about it.
Reply
#10
Solved: 4 Years, 6 Months, 2 Weeks ago
I think I might have found the issue, go into the mybb_usergroups and set the disporder for each usergroup from 1-8 that make sense?

So example disporder for Administrators is 4
Jack.D
Aspiring Web Developer
Reply
Jump to the post that solved this thread.


Forum Jump:


Users browsing this thread: 1 Guest(s)