Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Solved: 4 Years, 3 Months, 2 Weeks ago No registration IP
#1
Solved: 4 Years, 3 Months, 2 Weeks ago
When a user registers there is no ip address in admin panel for the user that registered. In MySQL database there are no ip addresses for that user either.

If the user makes a post or a thread the forum will insert an ip address. If I delete the users post or thread there is no longer any ip's for the user.

I have disable all plugins but it does not make any difference.

I uploaded the core files and it does not make any difference.

Anyone have any ideas?

Thanks,
Reply
#2
Solved: 4 Years, 3 Months, 2 Weeks ago
I worked on changing coding and removing plugins but nothing works.

I deleted two columns in my database "regip" and "lastip" and replaced them because they had letters in them so that when I was done they were blank.

I registered a test user. In the database under "lastip" was these letters ceffbeb3 

Does anyone know what happened?

Edit: I'm getting the last known ip after login, but I'm not getting the Registration IP:

Now it's logging this long number into the database under "regip" 37352e3132302e3135322e313935
Reply
#3
Solved: 4 Years, 3 Months, 2 Weeks ago
(07-30-2015, 02:40 PM)SouthernPride Wrote: I deleted two columns in my database "regip" and "lastip" and replaced them because they had letters in them so that when I was done they were blank.
IP addresses are stored in a binary format therefore they look "strange" in phpMyAdmin. If you delete those columns or change it's datatype MyBB can't store IPs correctly and errors may occur.
[Image: banner.png]
Reply
#4
Solved: 4 Years, 3 Months, 2 Weeks ago
Hi, so how can we correct this please so the IP addresses could be stored and displayed?
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)