Not Solved [Performance] Forum not updating when I edit CSS
#1
Not Solved
Hi I have a problem, its always worked fine but as of lately, when I do changes to the theme I have installed, it takes a while to show changes, when I edit templates it does the changes fine, but when its the CSS that I edit, it takes a while, sometimes a around 5-10 minutes, sometimes even longer than that

I tried with different browsers but it seems to be the same, is there a fix to this? I'd appreciate if someone can help me, thanks!
Reply
#2
Not Solved
ACP > tools & maintenance > cache manager > (Rebuild & Reload All)
Reply
#3
Not Solved
(2015-09-25, 05:47 PM)zukro Wrote: ACP > tools & maintenance > cache manager > (Rebuild & Reload All)

Thank you, I will try that but I have a question.. will that reset any of my templates/css edits? should I back them up first? thanks!
Reply
#4
Not Solved
are you using a proxy like cloudflare? It is also worth checking if you are caching your js css etc in a htaccess file. Running the tool as suggested by zukro will not harm your templates.
Random Fish and Sims Maniac
MY PLUGINS
Help MyBBSupport help you - remember to mark your threads as solved


Reply
#5
Not Solved
(2015-09-25, 06:15 PM)Leefish Wrote: are you using a proxy like cloudflare? It is also worth checking if you are caching your js css etc in a htaccess file. Running the tool as suggested by zukro will not harm your templates.

I just tried the Rebuild & Reload All option as suggested but it didnt work, im not using cloudflare or anything like that, I think its available from the hosting where I have my forum but I havent installed it or setting it up or anything like that, only installed mybb and themes, some plugins too, thats all

I have 2 htaccess on my root folder: htaccess.txt and another one, should I post it here?
Reply
#6
Not Solved
If you are using Cloudflare, activate Development mode, since Cloudflare is stupid.
Reply
#7
Not Solved
Post your .htaccess file here
-Ben

Please do not PM me for support. I am looking to be hired for paid services.

You can view my paid services here.
Reply
#8
Not Solved
It must be your browser cache. Try ctrl + F5 in your browser once you have completed the CSS edits.
Reply
#9
Not Solved
I tried the ctrl+F5 but its still not updating, not using cloudflare either, but here is my htaccess, by the way, my htaccess file name doesnt have a dot at the beginning, should I rename it to .htaccess?

---------

Options -MultiViews +FollowSymlinks -Indexes

#
# If mod_security is enabled, attempt to disable it.
# - Note, this will work on the majority of hosts but on
#   MediaTemple, it is known to cause random Internal Server
#   errors. For MediaTemple, please remove the block below
#
<IfModule mod_security.c>
# Turn off mod_security filtering.
SecFilterEngine Off

# The below probably isn't needed, but better safe than sorry.
SecFilterScanPOST Off
</IfModule>

#
# MyBB "search engine friendly" URL rewrites
# - Note, for these to work with MyBB please make sure you have
#   the setting enabled in the Admin CP and you have this file
#   named .htaccess
#
<IfModule mod_rewrite.c>
RewriteEngine on
RewriteRule ^forum-([0-9]+)\.html$ forumdisplay.php?fid=$1 [L,QSA]
RewriteRule ^forum-([0-9]+)-page-([0-9]+)\.html$ forumdisplay.php?fid=$1&page=$2 [L,QSA]

RewriteRule ^thread-([0-9]+)\.html$ showthread.php?tid=$1 [L,QSA]
RewriteRule ^thread-([0-9]+)-page-([0-9]+)\.html$ showthread.php?tid=$1&page=$2 [L,QSA]
RewriteRule ^thread-([0-9]+)-lastpost\.html$ showthread.php?tid=$1&action=lastpost [L,QSA]
RewriteRule ^thread-([0-9]+)-nextnewest\.html$ showthread.php?tid=$1&action=nextnewest [L,QSA]
RewriteRule ^thread-([0-9]+)-nextoldest\.html$ showthread.php?tid=$1&action=nextoldest [L,QSA]
RewriteRule ^thread-([0-9]+)-newpost\.html$ showthread.php?tid=$1&action=newpost [L,QSA]
RewriteRule ^thread-([0-9]+)-post-([0-9]+)\.html$ showthread.php?tid=$1&pid=$2 [L,QSA]

RewriteRule ^post-([0-9]+)\.html$ showthread.php?pid=$1 [L,QSA]

RewriteRule ^announcement-([0-9]+)\.html$ announcements.php?aid=$1 [L,QSA]

RewriteRule ^user-([0-9]+)\.html$ member.php?action=profile&uid=$1 [L,QSA]

RewriteRule ^calendar-([0-9]+)\.html$ calendar.php?calendar=$1 [L,QSA]
RewriteRule ^calendar-([0-9]+)-year-([0-9]+)-month-([0-9]+)\.html$ calendar.php?calendar=$1&year=$2&month=$3 [L,QSA]
RewriteRule ^calendar-([0-9]+)-year-([0-9]+)-month-([0-9]+)-day-([0-9]+)\.html$ calendar.php?action=dayview&calendar=$1&year=$2&month=$3&day=$4 [L,QSA]
RewriteRule ^calendar-([0-9]+)-week-(n?[0-9]+)\.html$ calendar.php?action=weekview&calendar=$1&week=$2 [L,QSA]

RewriteRule ^event-([0-9]+)\.html$ calendar.php?action=event&eid=$1 [L,QSA]

<IfModule mod_env.c>
SetEnv SEO_SUPPORT 1
</IfModule>
</IfModule>

#
# If Apache is compiled with built in mod_deflade/GZIP support
# then GZIP Javascript, CSS, HTML and XML so they're sent to
# the client faster.
#
<IfModule mod_deflate.c>
AddOutputFilterByType DEFLATE application/javascript text/css text/html text/xml
</IfModule>
Reply
#10
Not Solved
Which ISP, OS ? I have seen such problems happen until your ISP removes the cache. I cannot recall correctly but there is one Windows command to get rid of it.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)