Jump to the post that solved this thread.
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Solved: 3 Years, 8 Months, 3 Weeks ago [How To?] Disable Buddy Requests
#1
Solved: 3 Years, 8 Months, 3 Weeks ago
Is it possible to disable the buddy request?

I want to make it that when you click Add to Buddy List, it adds the user to your buddy list without the need for the user to accept your request.
Hello I'm Wally, the administrator of Sharree.com
Reply
#2
Solved: 3 Years, 8 Months, 3 Weeks ago
UCP -> Edit Options -> Automatically accept buddy requests (if the above checkbox is ticked, a PM is sent informing of the new buddy connection)

You can use this tutorial for the buddyrequestsauto field instead of classicpostbit: http://community.mybb.com/thread-40093.html
Reply
#3
Solved: 3 Years, 8 Months, 3 Weeks ago
Oh. Wasn't aware there was this option in UCP. Thanks Destroy666.
Hello I'm Wally, the administrator of Sharree.com
Reply
#4
Solved: 3 Years, 8 Months, 3 Weeks ago
Hey Destroy666,

So I updated the current userbase to '1' for buddyrequestauto

However any future registrations are '0' for buddyrequestauto

I tried doing the following:
I went into the structure of mybb_user and changed buddyrequestauto to a '1'
I also tried putting the following code on the registration page
<tr>
<td valign="top" width="1"><input type="checkbox" class="checkbox" checked="true" name="buddyrequestsauto" id="buddyrequestsauto" value="1" {$buddyrequestsautocheck} /></td>
<td valign="top"><span class="smalltext"><label for="buddyrequestsauto">{$lang->buddyrequestsauto}</label></span></td>
</tr>
Hello I'm Wally, the administrator of Sharree.com
Reply
#5
Solved: 3 Years, 8 Months, 3 Weeks ago
^ try changing checked="true" to checked="checked"
Reply
#6
Solved: 3 Years, 8 Months, 3 Weeks ago
Why are you adding a checkobox rather than hidden input if you want to force it? Anyways, for changing the default value everywhere, you'd have to edit inc/datahandlers/user.php. Change verify_yesno_option() for that field to 0.
Reply
#7
Solved: 3 Years, 8 Months, 3 Weeks ago
Because I am noob.

Thank you. That worked.
Hello I'm Wally, the administrator of Sharree.com
Reply
Jump to the post that solved this thread.


Forum Jump:


Users browsing this thread: 1 Guest(s)