Thread Rating:
  • 20 Vote(s) - 4.15 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[For 1.8] Square theme
(2016-04-08, 02:40 PM)zomgasd Wrote: How can I fix this green thing around the button?
http://imgur.com/N0fNPgX

You need to search the class of that button and then, remove the background property.
I don't give support on PM.
Reply
(2016-04-08, 02:46 PM)eNvy Wrote:
(2016-04-08, 02:40 PM)zomgasd Wrote: How can I fix this green thing around the button?
http://imgur.com/N0fNPgX

You need to search the class of that button and then, remove the background property.

Noob question: How can I do that? Will inspecting element work?

(2016-04-08, 03:11 PM)zomgasd Wrote:
(2016-04-08, 02:46 PM)eNvy Wrote:
(2016-04-08, 02:40 PM)zomgasd Wrote: How can I fix this green thing around the button?
http://imgur.com/N0fNPgX

You need to search the class of that button and then, remove the background property.

Noob question: How can I do that? Will inspecting element work?

2xPost Just tried, inspecting element helped, but not fix the issue Huh
Reply
(2016-04-08, 03:11 PM)zomgasd Wrote:
(2016-04-08, 02:46 PM)eNvy Wrote:
(2016-04-08, 02:40 PM)zomgasd Wrote: How can I fix this green thing around the button?
http://imgur.com/N0fNPgX

You need to search the class of that button and then, remove the background property.

Noob question: How can I do that? Will inspecting element work?

(2016-04-08, 03:11 PM)zomgasd Wrote:
(2016-04-08, 02:46 PM)eNvy Wrote:
(2016-04-08, 02:40 PM)zomgasd Wrote: How can I fix this green thing around the button?
http://imgur.com/N0fNPgX

You need to search the class of that button and then, remove the background property.

Noob question: How can I do that? Will inspecting element work?

2xPost Just tried, inspecting element helped, but not fix the issue Huh

I don't give support for plugins.

Yes, inspecting the element show you the HTML structure of that button, you need to search the specific class or id for that button and remove the background property from the CSS.
I don't give support on PM.
Reply
(2016-04-08, 03:25 PM)eNvy Wrote:
(2016-04-08, 03:11 PM)zomgasd Wrote:
(2016-04-08, 02:46 PM)eNvy Wrote:
(2016-04-08, 02:40 PM)zomgasd Wrote: How can I fix this green thing around the button?
http://imgur.com/N0fNPgX

You need to search the class of that button and then, remove the background property.

Noob question: How can I do that? Will inspecting element work?

(2016-04-08, 03:11 PM)zomgasd Wrote:
(2016-04-08, 02:46 PM)eNvy Wrote:
(2016-04-08, 02:40 PM)zomgasd Wrote: How can I fix this green thing around the button?
http://imgur.com/N0fNPgX

You need to search the class of that button and then, remove the background property.

Noob question: How can I do that? Will inspecting element work?

2xPost Just tried, inspecting element helped, but not fix the issue Huh

I don't give support for plugins.

Yes, inspecting the element show you the HTML structure of that button, you need to search the specific class or id for that button and remove the background property from the CSS.
I found it, however, when I removed the background it also removed the "Register" button background, it's inherited from the class.
Reply
(2016-04-08, 03:28 PM)zomgasd Wrote:
(2016-04-08, 03:25 PM)eNvy Wrote:
(2016-04-08, 03:11 PM)zomgasd Wrote:
(2016-04-08, 02:46 PM)eNvy Wrote:
(2016-04-08, 02:40 PM)zomgasd Wrote: How can I fix this green thing around the button?
http://imgur.com/N0fNPgX

You need to search the class of that button and then, remove the background property.

Noob question: How can I do that? Will inspecting element work?

(2016-04-08, 03:11 PM)zomgasd Wrote:
(2016-04-08, 02:46 PM)eNvy Wrote: You need to search the class of that button and then, remove the background property.

Noob question: How can I do that? Will inspecting element work?

2xPost Just tried, inspecting element helped, but not fix the issue Huh

I don't give support for plugins.

Yes, inspecting the element show you the HTML structure of that button, you need to search the specific class or id for that button and remove the background property from the CSS.
I found it, however, when I removed the background it also removed the "Register" button background, it's inherited from the class.

Then maybe the variable of the Steam button is INSIDE the register button, something like:

<span class="registerbutton">REGISTER {$steamlogin}</span>

If that's the case, you can move the variable ( {$steamlogin} ) out of the <span> tag.
I don't give support on PM.
Reply
(2016-04-08, 03:33 PM)eNvy Wrote:
(2016-04-08, 03:28 PM)zomgasd Wrote:
(2016-04-08, 03:25 PM)eNvy Wrote:
(2016-04-08, 03:11 PM)zomgasd Wrote:
(2016-04-08, 02:46 PM)eNvy Wrote: You need to search the class of that button and then, remove the background property.

Noob question: How can I do that? Will inspecting element work?

(2016-04-08, 03:11 PM)zomgasd Wrote: Noob question: How can I do that? Will inspecting element work?

2xPost Just tried, inspecting element helped, but not fix the issue Huh

I don't give support for plugins.

Yes, inspecting the element show you the HTML structure of that button, you need to search the specific class or id for that button and remove the background property from the CSS.
I found it, however, when I removed the background it also removed the "Register" button background, it's inherited from the class.

Then maybe the variable of the Steam button is INSIDE the register button, something like:

<span class="registerbutton">REGISTER {$steamlogin}</span>

If that's the case, you can move the variable ( {$steamlogin} ) out of the <span> tag.

I looked for it in the header_welcomeblock_guest (not sure if that was where I was supposed to look) this is the code that's integrated, I didn't find $steamlogin in it:
<a href="{$mybb->settings['bburl']}/misc.php?action=steam_login"><img border="0" src="http://steamcommunity-a.akamaihd.net/public/images/signinthroughsteam/sits_large_border.png" alt="Login through Steam" style="vertical-align:middle"></a></span>
Reply
(2016-04-08, 03:36 PM)zomgasd Wrote:
(2016-04-08, 03:33 PM)eNvy Wrote:
(2016-04-08, 03:28 PM)zomgasd Wrote:
(2016-04-08, 03:25 PM)eNvy Wrote:
(2016-04-08, 03:11 PM)zomgasd Wrote: Noob question: How can I do that? Will inspecting element work?


2xPost Just tried, inspecting element helped, but not fix the issue Huh

I don't give support for plugins.

Yes, inspecting the element show you the HTML structure of that button, you need to search the specific class or id for that button and remove the background property from the CSS.
I found it, however, when I removed the background it also removed the "Register" button background, it's inherited from the class.

Then maybe the variable of the Steam button is INSIDE the register button, something like:

<span class="registerbutton">REGISTER {$steamlogin}</span>

If that's the case, you can move the variable ( {$steamlogin} ) out of the <span> tag.

I looked for it in the header_welcomeblock_guest (not sure if that was where I was supposed to look) this is the code that's integrated, I didn't find $steamlogin in it:
<a href="{$mybb->settings['bburl']}/misc.php?action=steam_login"><img border="0" src="http://steamcommunity-a.akamaihd.net/public/images/signinthroughsteam/sits_large_border.png" alt="Login through Steam" style="vertical-align:middle"></a></span>

{$steamlogin} is just an example, in this case the code of the button is this:

<a href="{$mybb->settings['bburl']}/misc.php?action=steam_login"><img border="0" src="http://steamcommunity-a.akamaihd.net/public/images/signinthroughsteam/sits_large_border.png" alt="Login through Steam" style="vertical-align:middle"></a>

But again, this is inside a <span> tag, search if before the <a> tag starts there's something like <span class="name">, or just copy and paste the header_welcomeblock_guest here.
I don't give support on PM.
Reply
I've figured it out: <span> wasn't closed after the registerbutton, I had to add it! New problem my login button isn't working now! I can log in through the default MyBB theme, however not on Square.
{$lang->welcome_guest} <span class="loginbutton"><a href="{$mybb->settings['bburl']}/member.php?action=login" onclick="$('#quick_login').modal({ fadeDuration: 250, keepelement: true, zIndex: (typeof modal_zindex !== 'undefined' ? modal_zindex : 9999) }); return false;"><i style="font-size: 14px;" class="fa fa-sign-in fa-fw"></i> {$lang->welcome_login}</a></span> <span class="registerbutton"><a href="{$mybb->settings['bburl']}/member.php?action=register"><i style="font-size: 14px;" class="fa fa-user fa-fw"></i> {$lang->welcome_register}</a> </span> &mdash;  <a href="{$mybb->settings['bburl']}/misc.php?action=steam_login"><img border="0" src="http://steamcommunity-a.akamaihd.net/public/images/signinthroughsteam/sits_large_border.png" alt="Login through Steam" style="vertical-align:middle"></a></span>

				<div class="modal" id="quick_login" style="display: none;" 
	<form method="post" action="{$mybb->settings['bburl']}/member.php">
		<input name="action" type="hidden" value="do_login" />
		<input name="url" type="hidden" value="" />
		<input name="quick_login" type="hidden" value="1" />
      	<div class="welcometitle">
      		<h1>{$lang->xstyled_loginat} {$mybb->settings['homename']}</h1>
      	</div>
		<div class="welcomebox">
          	{$lang->xstyled_loginfirstphrase}<br /><br />
          	{$lang->xstyled_loginsecondphrase}<br /><br />
          	{$lang->xstyled_loginthirdphrase}
      	</div>
      	<div class="welcomelogin">
          	<ul>
				<li><span class="log"><i class="fa fa-user fa-fw"></i></span><input name="quick_username" id="quick_login_username" type="text" value="Username" class="textlog" size="25" /></li>
				<li><span class="log"><i class="fa fa-lock fa-fw"></i></span><input name="quick_password" id="quick_login_password" type="password" value="Password" class="textlog" size="25" /></li>
			</ul>
          	<br style="clear: both;"/>
          	<input name="quick_remember" id="quick_login_remember" type="checkbox" value="yes" class="checkbox" checked="checked" />
            <label for="quick_login_remember" style="color: #363636;">{$lang->remember_me}</label><br />
          	<a href="{$mybb->settings['bburl']}/member.php?action=lostpw" class="lost_password">{$lang->lost_password}</a>
			<br style="clear: both;"/><br />
          	<input class="loginbutton" name="submit" type="submit" value="{$lang->login}" style="cursor: pointer;" />
			<span class="registerbutton"><a href="{$mybb->settings['bburl']}/member.php?action=register"><i style="font-size: 14px;" class="fa fa-user fa-fw"></i> {$lang->welcome_register}</a> &mdash; <a href="{$mybb->settings['bburl']}/misc.php?action=steam_login"><img border="0" src="http://steamcommunity-a.akamaihd.net/public/images/signinthroughsteam/sits_large_border.png" alt="Login through Steam" style="vertical-align:middle"></a></span>
      	</div>
	</form>
</div>

<script type="text/javascript">
	$("#quick_login input[name='url']").val($(location).attr('href'));
</script>
Reply
(2016-04-08, 04:19 PM)zomgasd Wrote: I've figured it out: <span> wasn't closed after the registerbutton, I had to add it! New problem my login button isn't working now! I can log in through the default MyBB theme, however not on Square.
{$lang->welcome_guest} <span class="loginbutton"><a href="{$mybb->settings['bburl']}/member.php?action=login" onclick="$('#quick_login').modal({ fadeDuration: 250, keepelement: true, zIndex: (typeof modal_zindex !== 'undefined' ? modal_zindex : 9999) }); return false;"><i style="font-size: 14px;" class="fa fa-sign-in fa-fw"></i> {$lang->welcome_login}</a></span> <span class="registerbutton"><a href="{$mybb->settings['bburl']}/member.php?action=register"><i style="font-size: 14px;" class="fa fa-user fa-fw"></i> {$lang->welcome_register}</a> </span> &mdash;  <a href="{$mybb->settings['bburl']}/misc.php?action=steam_login"><img border="0" src="http://steamcommunity-a.akamaihd.net/public/images/signinthroughsteam/sits_large_border.png" alt="Login through Steam" style="vertical-align:middle"></a></span>

				<div class="modal" id="quick_login" style="display: none;" 
	<form method="post" action="{$mybb->settings['bburl']}/member.php">
		<input name="action" type="hidden" value="do_login" />
		<input name="url" type="hidden" value="" />
		<input name="quick_login" type="hidden" value="1" />
      	<div class="welcometitle">
      		<h1>{$lang->xstyled_loginat} {$mybb->settings['homename']}</h1>
      	</div>
		<div class="welcomebox">
          	{$lang->xstyled_loginfirstphrase}<br /><br />
          	{$lang->xstyled_loginsecondphrase}<br /><br />
          	{$lang->xstyled_loginthirdphrase}
      	</div>
      	<div class="welcomelogin">
          	<ul>
				<li><span class="log"><i class="fa fa-user fa-fw"></i></span><input name="quick_username" id="quick_login_username" type="text" value="Username" class="textlog" size="25" /></li>
				<li><span class="log"><i class="fa fa-lock fa-fw"></i></span><input name="quick_password" id="quick_login_password" type="password" value="Password" class="textlog" size="25" /></li>
			</ul>
          	<br style="clear: both;"/>
          	<input name="quick_remember" id="quick_login_remember" type="checkbox" value="yes" class="checkbox" checked="checked" />
            <label for="quick_login_remember" style="color: #363636;">{$lang->remember_me}</label><br />
          	<a href="{$mybb->settings['bburl']}/member.php?action=lostpw" class="lost_password">{$lang->lost_password}</a>
			<br style="clear: both;"/><br />
          	<input class="loginbutton" name="submit" type="submit" value="{$lang->login}" style="cursor: pointer;" />
			<span class="registerbutton"><a href="{$mybb->settings['bburl']}/member.php?action=register"><i style="font-size: 14px;" class="fa fa-user fa-fw"></i> {$lang->welcome_register}</a> &mdash; <a href="{$mybb->settings['bburl']}/misc.php?action=steam_login"><img border="0" src="http://steamcommunity-a.akamaihd.net/public/images/signinthroughsteam/sits_large_border.png" alt="Login through Steam" style="vertical-align:middle"></a></span>
      	</div>
	</form>
</div>

<script type="text/javascript">
	$("#quick_login input[name='url']").val($(location).attr('href'));
</script>

Try disabling the plugin and see if you can login.
I don't give support on PM.
Reply
(2016-04-08, 05:10 PM)eNvy Wrote:
(2016-04-08, 04:19 PM)zomgasd Wrote: I've figured it out: <span> wasn't closed after the registerbutton, I had to add it! New problem my login button isn't working now! I can log in through the default MyBB theme, however not on Square.
{$lang->welcome_guest} <span class="loginbutton"><a href="{$mybb->settings['bburl']}/member.php?action=login" onclick="$('#quick_login').modal({ fadeDuration: 250, keepelement: true, zIndex: (typeof modal_zindex !== 'undefined' ? modal_zindex : 9999) }); return false;"><i style="font-size: 14px;" class="fa fa-sign-in fa-fw"></i> {$lang->welcome_login}</a></span> <span class="registerbutton"><a href="{$mybb->settings['bburl']}/member.php?action=register"><i style="font-size: 14px;" class="fa fa-user fa-fw"></i> {$lang->welcome_register}</a> </span> &mdash;  <a href="{$mybb->settings['bburl']}/misc.php?action=steam_login"><img border="0" src="http://steamcommunity-a.akamaihd.net/public/images/signinthroughsteam/sits_large_border.png" alt="Login through Steam" style="vertical-align:middle"></a></span>

				<div class="modal" id="quick_login" style="display: none;" 
	<form method="post" action="{$mybb->settings['bburl']}/member.php">
		<input name="action" type="hidden" value="do_login" />
		<input name="url" type="hidden" value="" />
		<input name="quick_login" type="hidden" value="1" />
      	<div class="welcometitle">
      		<h1>{$lang->xstyled_loginat} {$mybb->settings['homename']}</h1>
      	</div>
		<div class="welcomebox">
          	{$lang->xstyled_loginfirstphrase}<br /><br />
          	{$lang->xstyled_loginsecondphrase}<br /><br />
          	{$lang->xstyled_loginthirdphrase}
      	</div>
      	<div class="welcomelogin">
          	<ul>
				<li><span class="log"><i class="fa fa-user fa-fw"></i></span><input name="quick_username" id="quick_login_username" type="text" value="Username" class="textlog" size="25" /></li>
				<li><span class="log"><i class="fa fa-lock fa-fw"></i></span><input name="quick_password" id="quick_login_password" type="password" value="Password" class="textlog" size="25" /></li>
			</ul>
          	<br style="clear: both;"/>
          	<input name="quick_remember" id="quick_login_remember" type="checkbox" value="yes" class="checkbox" checked="checked" />
            <label for="quick_login_remember" style="color: #363636;">{$lang->remember_me}</label><br />
          	<a href="{$mybb->settings['bburl']}/member.php?action=lostpw" class="lost_password">{$lang->lost_password}</a>
			<br style="clear: both;"/><br />
          	<input class="loginbutton" name="submit" type="submit" value="{$lang->login}" style="cursor: pointer;" />
			<span class="registerbutton"><a href="{$mybb->settings['bburl']}/member.php?action=register"><i style="font-size: 14px;" class="fa fa-user fa-fw"></i> {$lang->welcome_register}</a> &mdash; <a href="{$mybb->settings['bburl']}/misc.php?action=steam_login"><img border="0" src="http://steamcommunity-a.akamaihd.net/public/images/signinthroughsteam/sits_large_border.png" alt="Login through Steam" style="vertical-align:middle"></a></span>
      	</div>
	</form>
</div>

<script type="text/javascript">
	$("#quick_login input[name='url']").val($(location).attr('href'));
</script>

Try disabling the plugin and see if you can login.

I disabled the Steam Plugin, it still didn't bother working
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)