Jump to the post that solved this thread.
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Solved: 3 Years, 3 Months, 1 Week ago MyBB Error 44 [raspberry pi]
#1
Solved: 3 Years, 3 Months, 1 Week ago
I have tried googling and searching for an answer for this and tried the fix it had stated in the wiki to change 
$config['database']['type'] = 'mysqli';          to          $config['database']['type'] = 'mysql';
It did not work.  Sad

This is the actual message 
Error Type:
MyBB Error (44)
Error Message:
MyBB was unable to load the SQL extension. Please contact the MyBB Group for support. MyBB Website
Reply
#2
Solved: 3 Years, 3 Months, 1 Week ago
as changing the database type did not work you have to contact your web host for fixing it
Reply
#3
Solved: 3 Years, 3 Months, 1 Week ago
When you say contact my webhost, do you mean contact godaddy(place where I bought my domain name) or something? I am running this off of my raspberry pi.
Reply
#4
Solved: 3 Years, 3 Months, 1 Week ago
so your web server is RPI ? sorry I've no knowledge about it .. check if this helps
Reply
#5
Solved: 3 Years, 3 Months, 1 Week ago
I have done all of these already. I still have the same issue :C
Reply
#6
Solved: 3 Years, 3 Months, 1 Week ago
see if replies here have a clue ..
Reply
#7
Solved: 3 Years, 3 Months, 1 Week ago
Do you have php5-mysql installed? If not MyBB and PHP won't have an interface to connect to MySQL. Since your running this off a raspberry pi you'll be following the same procedure you'd follow on a VPS or Dedi.
Software Engineer specializing in Crystal Program Development

Reply
#8
Solved: 3 Years, 3 Months, 1 Week ago
As MyZeus says, your custom server is not correctly configured.
Reply
#9
Solved: 3 Years, 3 Months, 1 Week ago
Out of interest why you would you want to use the older MySQL extension over the MySQLi extension? If I remember correctly, the MySQL connection is/was actually planned to be removed from PHP entirely.
MyReactions - All Plugins

Can you still feel the butterflies?

Free never tasted like pudding.
Reply
#10
Solved: 3 Years, 3 Months, 1 Week ago
I had that revered, my bad( I had changed MySQL to MySQLi) . And btw I solved it. I had to make sure that inc/settings.php had been switch to my domain name, for some reason it did not do that on install. TY for all the help tho.
Reply
Jump to the post that solved this thread.


Forum Jump:


Users browsing this thread: 1 Guest(s)