Jump to the post that solved this thread.
Solved: 5 Years, 7 Months, 1 Week ago [PICTURE] Removing this: where it says "user this post has been deleted"
#1
Solved: 5 Years, 7 Months, 1 Week ago
I would like to remove the notification left behind when posts are deleted.

[Image: FqyvvW9.png]
Reply
#2
Solved: 5 Years, 7 Months, 1 Week ago
The posts are only soft deleted; in 1.8.9 we changed soft deleted posts to be displayed like this, before 1.8.9 the posts would still be visible to moderators/admins, but would be purple to show they'd been deleted. If you don't want posts to be soft deleted, go to ACP > Configuration > Posting > Enable Soft Delete for Users, and set this to No, and posts will then be permanently deleted.
MyReactions - All Plugins

Can you still feel the butterflies?

Free never tasted like pudding.
Reply
#3
Solved: 5 Years, 7 Months, 1 Week ago
It is set to no. I (admin) deleted the post permanently. When I switch to my test account (regular user) that is when I see the above notification.
Reply
#4
Solved: 5 Years, 7 Months, 1 Week ago
If the post is deleted permanently this wouldn't be showing up, and regular users can't see soft deleted posts. Are you sure your permissions are set up correctly? Because if the above is happening on your forum, it sounds quite badly misconfigured.
MyReactions - All Plugins

Can you still feel the butterflies?

Free never tasted like pudding.
Reply
#5
Solved: 5 Years, 7 Months, 1 Week ago
Logged in as the admin I went to an individual post and hit delete. When I'm logged in as the admin I don't get that message in threads pictured above.

My test account has regular registered user permissions. I have not edited any permissions. And that's when I see the picture above when I enter the thread that had posts deleted.

I didn't do anything that would cause this. Could it be a something in the theme template? Or is there a way I could edit this notification out in general so no one would see that message?
Reply
#6
Solved: 5 Years, 7 Months, 1 Week ago
Hitting 'delete' only soft deletes it like I say, to permanently delete it, you need to use the moderation options in the thread.

What you're saying though seems backwards - the admin user is the one who should see this message, the regular user should not.

Can you PM me the login details for both accounts, and the URL to the thread - either your permissions are completely broken on your forum, or the accounts are being mixed up.
MyReactions - All Plugins

Can you still feel the butterflies?

Free never tasted like pudding.
Reply
#7
Solved: 5 Years, 7 Months, 1 Week ago
Okay, all sorted.

First issue was your theme hasn't been updated to 1.8.9, so I had to make a few small changes - this is why your admin account didn't see the notice. The second issue was that by default the 'Registered' group can see deletion notices (it's not the same one as the admins see), which is why the test account could see the message. This permission is different for new installs and upgrades, so I didn't realise it worked like this until just now Smile

Anyway, is now working as it should. For the posts that have currently been soft deleted, you'll need to click 'show this post', then delete it, or use the inline moderation tools, to permanently delete it.
MyReactions - All Plugins

Can you still feel the butterflies?

Free never tasted like pudding.
Reply
#8
Solved: 5 Years, 7 Months, 1 Week ago
Alright thank you so much for your time and knowledge! Very much appreciated, sorry if it was a bother.
Reply
#9
Solved: 5 Years, 7 Months, 1 Week ago
No worries, just seemed very confusing at first when each account was doing the opposite to what I expected! Big Grin
MyReactions - All Plugins

Can you still feel the butterflies?

Free never tasted like pudding.
Reply
#10
Solved: 5 Years, 7 Months, 1 Week ago
(2017-01-01, 04:50 PM)Matt Wrote: No worries, just seemed very confusing at first when each account was doing the opposite to what I expected! Big Grin

I have this exact issue. Can you share what you would have done to the theme to fix it?
Reply
Jump to the post that solved this thread.


Forum Jump:


Users browsing this thread: 1 Guest(s)