Jump to the post that solved this thread.
Solved: 3 Years, 8 Months, 4 Weeks ago I am unable to set so that new posts DO NOT required moderation.
#1
Solved: 3 Years, 8 Months, 4 Weeks ago
After posting a new post as a user, it throws this message, "The administrator has specified that all new posts require moderation."  I want to disable this requirement.

I am using myBBversion 1.8.12, which I installed a couple of days ago.
My website is on a hosting company and I installed myBB using their scripts.
PHP version 5.2.17
SQL Engine mySQLi 5.6.36

My URL to the forum: http://cmeton.com/mybb

I think I have the moderation requirement inactivated in all forums, but it still requires me to wait for moderation after a new post unless I post as the administrator.

In the "Permissions" tab of my forum permissions, on the "Moderation" tab of the pop-up window, all of the boxes are unchecked as follows:  "Moderate new posts, Moderate new threads, Moderate posts after they've been edited, Moderate new attachments."

What have I done incorrectly and how can I make it accept new posts immediately without requiring moderator approval?  Did I do something wrong when I installed myBB?

Before registering on this forum, I had searched with Google and followed all the instructions that I could find, but none of them gave me the results I seek.


Thank you.

I don't remember, but maybe I set something during installation that made it always require moderation(?)
Reply
#2
Solved: 3 Years, 8 Months, 4 Weeks ago
can you check this link

YOURFORUM.com/YOUR-ADMIN-FOLDER/index.php?module=user-groups&action=edit&gid=2#tab_forums_posts

maybe this area

[Image: 2YvQ_ldaRdqi2F-sZbdQsg.jpg]

cmeton.com/mybb/YOUR-ADMIN-FOLDER/index.php?module=user-groups&action=edit&gid=2#tab_forums_posts
[Image: ziuma.jpg]    
Reply
#3
Solved: 3 Years, 8 Months, 4 Weeks ago
Yes, all 4 boxes are unchecked, just as they appear in your post.  I tried to post again this morning and it still wants moderator approval.  I have some errands I have to run today, but I will get back to this as soon as I can.
 
Thanks for the quick response to my query.

Since I am new to myBB, I may have missed a setting somewhere.  I'll go back through everything I can find and see if there are still any moderation boxes checked somewhere.  I did find some checked last night and I unchecked them, but it is still requiring moderator approval so maybe I missed some other check boxes.
Reply
#4
Solved: 3 Years, 8 Months, 4 Weeks ago
read this threads, maybe can help you

https://community.mybb.com/post-1146489.html
[Image: ziuma.jpg]    
Reply
#5
Solved: 3 Years, 8 Months, 4 Weeks ago
I followed the instructions on that thread, made sure the moderation boxes were all unchecked, saved the forum, etc., and then added a new reply from the user account and it still says, "The administrator has specified that all new posts require moderation.  You will now be returned to the thread."

I give up. I am going to deinstall myBB and start over from scratch. Perhaps I did something wrong during the installation process.

Well, I copied the forum to a new forum and the new one requires moderation too.
Reply
#6
Solved: 3 Years, 8 Months, 4 Weeks ago
YAY, I FOUND THE SOLUTION!

After closing the forum and deleting all of my forums and then trying to de-install the myBB softare...

I could not find a way to deinstall it on my server, other than by just deleting the files and database, so I went back in as Admin and poked around some more.

The problem was that "Moderate Posts" was checked on the USER's profile of the user who was experiencing the messages saying that moderation was required.

I wish I had discovered that before I had wiped out all of my forums.

Live and learn.  I'm happy now.
Big Grin

The box was checked under:

Users & Groups / Browse Users / user who was having the problem / Options / Edit Profile & Settings / Moderator Options / Moderate Posts

I tried to paste a screen capture here, but when I post it, it changes from an image to a monsterous hex dump.

So, I don't know yet how to post images to a thread.

Thanks, everyone, for your help!
Reply
Jump to the post that solved this thread.


Forum Jump:


Users browsing this thread: 1 Guest(s)