Jump to the post that solved this thread.
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Not Solved "s" character on EVERY page of my forum
#1
Not Solved
Hello.
Recently, "s" character started appearing on every single page of my forum, including USER CP.

Because of that character, my captcha on registartion form is not working, it's displaying 404 error image, like that image doesnt exist, and when I click on it and go to view image in new tab, I see only character "s". I'll drop you some images. Can someone tell me which templates shoud I check or what caused this? Im pretty sure I didnt type that "s" character anywhere nor I was logged in to Admin CP when that "bug" appeared. Thanks.


[Image: EYlHNUwjQhmoNNRYNfUN6g.png][Image: rDiGmeHoTHKlF7I-OOCWGQ.png][Image: w_z6dyocQYmKscWph2SRLA.png]
Reply
#2
Not Solved
What have you edited recently? In templates or core?
Reply
#3
Not Solved
(01-15-2018, 03:46 PM)metulburr Wrote: What have you edited recently? In templates or core?

Well, that's the problem. I did not edit any templates recently.
I mean, I did, 2 or 3 of them, but they are not about that, and I already checked them, and there is no S character at all.
Reply
#4
Not Solved
Well what are those that you did modify? The point is to double check by another person.

You could of added an s or removed a bracket allowing a character to show that is not suppose to
Reply
#5
Not Solved
temporarily disable all the plugins. do you still get that S ?

forum admin panel >> configuration (settings) >> General Configuration --> Disable All Plugins.
Reply
#6
Not Solved
(01-15-2018, 03:54 PM).m. Wrote: temporarily disable all the plugins. do you still get that S ?

forum admin panel >> configuration (settings) >> General Configuration --> Disable All Plugins.

Hey. I did. No, Im not getting that "s" character when I disable all plugins, and all errors are fixed.
Reply
#7
Not Solved
Then one of your plugins is doing it. Activate each plugin one by one to find which it is. Check your templates for the plugin, and php files for a rogue s
Reply
#8
Not Solved
I'm testing all plugin files right now, I'll let you guys know if I fix it, thanks.
Reply
#9
Not Solved
can you list the plugin files you have ..
or which plugins you have installed recently ?

basically you have to deactivate plugins one by one &
simultaneously check if the issue gets resolved ..
Reply
#10
Not Solved
I found what causes s character to be displayed. I fixed it now. There was an S without any code (s than start of the file - s<?php). I really dont remember when I edited that file because it was in MySubscriptions plugin and I added it a long time ago.

Thanks guys.
Reply
Jump to the post that solved this thread.


Forum Jump:


Users browsing this thread: 1 Guest(s)